0

I have 2 Pi's and a laptop;

pi.local - Already setup and running, using staic IP and connected through LAN

pi.wifi - Partially setup, causing a problem, which this question is about.

laptop - Macos x Yosemite

When I'm connecting from Laptop to pi.wifi I get a "Connection timeout".

I've tried a number of things, trying to figure out where the error is, but to no avail. I've tried the following...

  • Using sudo raspi-config to enable SSH, and this seems to be working. Reboot after done config - No errors.

  • Connecting from laptop to pi.local everything is fine. I get connection and everything works.

  • I can connect from pi.wifi to pi.wifi. I've tried connecting to both 127.0.0.1 and the real ip, with no problems. This suggest that the SSH works on pi.wifi

  • The odd parts is, that if i connect from laptop to pi.local and use that connection to make a new connection to pi.wifi, everything goes smooth. This confirms that SSH works on pi.wifi

  • I've tried to remove the key, using ssh-keygen -R IP_BE_HERE from laptop, just to make sure.

  • The pi.wifi has no problems getting on the wifi. All my ping attempts from pi.wifi to e.g. Google goes through just fine.

  • When pinging from pi.local to pi.wifi, everything is fine, but when pinging from laptop to pi.wifi I get a timeout.

My suspicion goes toward some error between laptop and pi.wifi, but I simply cannot put my finger on what could be wrong!

Can someone help get on with this?

  • You need to have a look at where packets are going on the network using a tool such as wireshark, which is available for OSX and the pi via distro installer (for raspbian, apt-get). It doesn't matter which machine on the LAN you run this on, either of those or a completely different one (since all traffic on the LAN is actually visible to all machines, this is the nature of networking). – goldilocks Jan 21 '15 at 21:20
  • You may know what you mean by pi.local and pi.wifi but it is far from clear. pi.local looks line the OS X description of a zero conf connection – Milliways Jan 21 '15 at 23:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.