0

I am trying to install OpenELEC v5.0 (Kodi) on my Raspberry Pi B+. Strangely, I get the startup screen with Pictures, Music etc options but the UI just freezes/hangs after every single reboot.

I can SSH into the Pi properly and top doesn't reveal anything unusual. If I am lucky, I get about a minute before which it freezes again. During the brief interval before it freezes, I have verified that CEC (remote control) and mouse work.

I use ethernet cable for connecting the Pi to the internet.

I have tried swapping HDMI cables, power adapters and even versions of OpenELEC with no luck. When I tried with OpenELEC v4.2.1 though, I get a few more minutes of operational time before it decides to freeze.

I have run out of all options here and would appreciate any help.

Additionally, my friend who has the model B, has successfully managed to run OpenELEC v5.0 without freezing.

1

I think you could have either an issue with the SD card, or you could have limited power being supplied to the rPi. Both could cause the problems you are having. Take your SD card and try boot it on your friends rPi and see if it boots, if it does leaves you with power supply issues. If it does not then obviously your SD card.

Also have a look at this quick article.

Reasons raspberry pi does not work properly

  • I have tried using both the 12W iPad charger which is around 5V at 2.4A and one which came with the Raspberry Pi kit that I purchased with no difference. That leaves me to try out the SD card swap you suggested. – adarshr Jan 30 '15 at 9:13
  • Awesome. How did it fair out with the SD card swop? – Kwekuq Feb 2 '15 at 8:10
  • I have actually ordered a new 16GB Class 10 SD card. Will see how it goes. – adarshr Feb 2 '15 at 9:08
  • Did it work properly with your new SD Card now ? I got the same problem, so if it solve it I know what to do... – user27655 Mar 4 '15 at 20:01
  • I was guessing the silence proved it to be solve, else would have been back for more advice. But I would also like to hear confirmation if it did really work. – Kwekuq Mar 6 '15 at 8:11

protected by Community Mar 6 '15 at 23:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.