3

Both my laptop and my raspberry pi b+ are connected to a wifi router in the house (to which I do not have direct access).

I ran ifconfig to find the pi's ip and tried to ping the pi from my laptop, and I get this:

ping 192.168.2.110

PING 192.168.2.110 (192.168.2.110) 56(84) bytes of data.
From 192.168.2.103 icmp_seq=1 Destination Host Unreachable
From 192.168.2.103 icmp_seq=2 Destination Host Unreachable
From 192.168.2.103 icmp_seq=3 Destination Host Unreachable
From 192.168.2.103 icmp_seq=4 Destination Host Unreachable
From 192.168.2.103 icmp_seq=5 Destination Host Unreachable
From 192.168.2.103 icmp_seq=6 Destination Host Unreachable
^C
--- 192.168.2.110 ping statistics ---
8 packets transmitted, 0 received, +6 errors, 100% packet loss, time 7040ms
pipe 3

SSH gives the same answer, Host Unreachable. :(

EDIT: I also used nmap from my laptop and it found no hosts on the network

Nmap done: 254 IP addresses (0 hosts up) scanned in 103.21 seconds

EDIT: Another interesting thing is that arp-scan says:

sudo arp-scan --interface=wlan0 --localnet
Interface: wlan0, datalink type: EN10MB (Ethernet)
Starting arp-scan 1.8.1 with 256 hosts (http://www.nta-monitor.com/tools/arp-       scan/)
192.168.2.1 60:e7:01:79:4d:49   (Unknown)
192.168.2.109   90:f1:aa:b7:c1:09   (Unknown)

2 packets received by filter, 0 packets dropped by kernel

Also I used Fing on my tablet, and it can see phones, tv, my laptop, everything EXCEPT the damn Pi. And I have enabled SSH in raspi-config. Anyone know why the pi is not visible?

  • 1
    Something is not right with network. You ping 192.168.2.110 and it answers once, then all of a sudden it starts to ping 192.168.2.103... I guess the most obvious thing to ask is 1. Are both devices in same range (192.168.2.x). I mean the Pi and you laptop. Have you used raspi-config to make sure ssh is enabled (its under advanced. Or you can sudo service ssh status – geoffmcc Feb 1 '15 at 14:54
  • It does not start to ping 103, 103 is my laptop, all lines say: From ....103 – Qubix Feb 4 '15 at 20:23
  • My bad. Looked at it wrong. – geoffmcc Feb 4 '15 at 20:41
2

Take a look to your Wifi Router. Maybe it does not allow communication between different Wifi Hosts in his Network. This would apply to the fact that the router itself and internet is reachable.

0

The Pi could be on another address. When I scan my network with the iOS tool Fing, I can find the address of my Pi. It's easy to find in the list with the name Raspberry Pi Foundation. Fing is also available for other systems, including Windows. http://www.overlooksoft.com/download

  • I forgot to mention, I am running Linux Mint 17 on my laptop. The same message happens when I ping my laptop from my Pi. How can I get Fing for linux ? – Qubix Jan 31 '15 at 17:50
  • Mint is Debian, right? There are also versions for the main Linux distributions available. I forgot to ask, why do you need to ping? It's possible Ping is disabled in your router. – Non Plus Ultra Jan 31 '15 at 17:56
  • I tried ssh-ing to my raspberry pi and it said host unreachable, so I tried ping and it says the same thing. I'm pretty sure it's the correct IP address, but can I do anything if the router is not under my control ? – Qubix Jan 31 '15 at 17:58
  • If SSH port is disabled you might try setting another port which is not blocked. – Non Plus Ultra Jan 31 '15 at 23:51
  • To find a Pi on a network, install nmap on your Mint box and try this: sudo nmap -sP 192.168.2.0/24 | awk '/^Nmap/{ip=$NF}/B8:27:EB/{print ip}' – ripat Feb 1 '15 at 6:37
0

you should connect the TV to your RPi to find out what's going on with the network, is it working properly and what is the allocated IP address. after that, you may try to check if sshd is actually started and listening to the port.

and please, don't tell us you don't have access to the TV.

0

Ok first I'll start (if I were you) diagnostic the raspberryPi :

From the raspberry

1- Can you ping your wifi router ?
2- Can you ping google (internet access??)
3- Can you ping your laptop ?

1-2-3 OK ? Your raspberry is connected properly to your router.

4- Can you connect to your own ssh server ?

$ ssh localhost 

No ? try that :

# /etc/init.d/sshd restart  

OR

# service sshd restart  

If it doesn't work, you have an issue with your ssh server.
If it works, you have an issue in your laptop !

  • 1
    1- YES 2- YES, 3 - NO. When I ping my laptop it says "Destination host unreachable". Same for when I ping my raspberry pi from my laptop. – Qubix Feb 4 '15 at 19:58
  • Do you have a firewall somewhere ? (laptop ? wifi router ?) – user2629409 Feb 5 '15 at 9:42
  • same with @Qubix – delai Feb 24 '18 at 16:54
  • Check your network settings. If you don't have any firewall, you should be able to ping without any problem. Warning: the firewall can be embedded in your router :) – user2629409 Feb 26 '18 at 9:06
0

I think that your problem could be a disabled SSH server. Before I explain my solutions, make sure your firewall allows communication between the Raspberry Pi and your computer. If that didn't work, here are my solutions:

1. Connect your Raspberry Pi to a TV and keyboard. You should see the terminal screen. Login with your Raspberry Pi credentials and then type the following command: "sudo raspi-config." You should be greeted with a screen. Using the keyboard keys, navigate to *Advanced Options, click SSH and then enter Enable. You should now be able to access your Raspberry Pi through SSH.

If that didn't work, here is my final solution:

2. I am assuming you have Raspian or something similar as the Raspberry Pi's OS, * format & reinstall a FRESH copy of the OS image onto the SD card and try again.*

If none of these work, your router is most likely at fault or is tunneling data elsewhere.

~Shayan Doust

0

Late to the party here, but I want to post my solution for others who find this thread.

You may need to reboot the router!

Here's the debug steps I took to get to that point.

On the pi:

Let's first be a little paranoid and check hosts.deny and our firewall to make sure nothing's weird there.

cat /etc/hosts.deny and make sure it's empty, or that every line is commented out thus it's effectively empty.

iptables -L This should fail with some message about "Operation not permitted" and "can't initialize iptables table ...". Failure here is good!

Okay, now let's do some basic network debugging steps.

ps -ef | grep ssh to see that sshd is indeed running.

ping google.com for a few seconds to confirm that it has outbound connectivity to the network.

sudo apt-get install telnet because telnet is useful for debugging network issues

telnet localhost 22 and confirm that it connects. Use ^] to disconnect.

ssh localhost and see if it works. You don't have to go all the way through the process, if it returns with a public key and asks yes/no if you want to connect, that's proof enough that it's working. Just Ctrl + c out of it.

On your laptop (I was using OSX, adapt as necessary for Windows)

If the following debugging steps all fail, then try rebooting your router. If any of these succeed, then the router is not your issue.

ssh pi@<ip address from hostname -I on the pi> presumably you already tried this and it already failed, which is what brought you to this thread!

telnet <ip address> 22 to see if anything is listening on 22. If the router is your issue, this will fail. You don't need to wait minutes for it to timeout, if it doesn't work within 5 seconds just Ctrl + c. If this actually succeeds, then the router is not your issue.

ping <ip address> and confirm that it fails. Again, if this succeeds then it's not the router.

Now that you've done all that, go reboot the router.

When it comes back up, toggle the wireless connection on your Pi off and on and check hostname -I to see if you have a new IP or the same.

For me, I was able to immediately ssh pi@<ip> successfully once the router came back up.

Looks like the original poster found a different solution, but I hope this helps somebody else out there!

---UPDATE----

This doesn't change anything above, but there's an additional problem with SSH'ing to the Pi which actually has its roots in power management for the wifi chip. It'll power down after 1 minute of inactivity by default, so if you are successfully connected, then flip away for 60 seconds and come back, your connection may have dropped.

If you're having this problem, use the solution from a Pi engineer here: https://discourse.osmc.tv/t/pi-3-wifi-unstable/14171/2 which is to turn the power management off by using:

sudo iwconfig wlan0 power off

-2

Um. I think I may have an answer here. This will also prove how dumb I am, but in the interest of helping out ... [ :) ]

I had exactly the same problem. Turns out my laptop was connected the main home network on my router while I had signed up my Rasp Pi to the guest network on the same router. So, Raspi gets internet, pings router etc., all okay, and so does my computer/laptop, but they don't ping each other, and naturally SSH doesn't work.

Solution: Got Raspi on main home network!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.