Initially, my Raspberry Pi B+ was working fine, but after I play with some GPIO pins, I got the following message immediately after the rainbow screen while booting the device.

sh: can't access tty; job control turned off
/ #

Then, I unplug all the pins and boot it again. Still got the same message. I also added avoid_safe_mode=1 in /boot/config.txt, but still no luck. Then, I formatted my SD card and put a fresh NOOBS on it, but I still see the same message. Any suggestion what other things I can try? Or the Pi has died? Thank you

  • Good idea to format the SD card. You could try with a fresh card perhaps. Are there any other messages before the one you post? I assume what you post is the last one seen. The GPIO pins are known to be somewhat sensitive to overvoltage and other abuse. Still the pi seems not completely dead since it gets so far as to get sh running. – Frepa Feb 5 '15 at 10:06
  • Thanks for your reply. What I observed during booting was as follows: 1. power on (red indicator light on, green light flashes twice). 2. red light is still on, and the green light is off. 3. rainbow screen on the monitor. 4. safe mode that shows the message above immediately after the rainbow screen. The formatted SD card should be okay because the card works on another Pi of mine. – pohe Feb 5 '15 at 14:20

I had the same problem that wasn't fixed by adding avoid_safe_mode. It was fixed by adding disablesafemode to the end of recovery.cmdline (in the RECOVERY partition).

My recovery.cmdline for reference:

quiet vt.cur_default=1 elevator=deadline disablesafemode

Have you got a case with a fan built into it, or any other device connected to the GPIOs pins? I have this problem with my Raspberry Pi 2, I have to disconnect the fan to boot it up then attach the fan back onto the GPIOs pins when it is booted up. Have you tried removing all peripherals from your Pi before booting?

  • Why do you think it would be a problem of fans? – Bex Mar 30 '15 at 5:34

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.