5

I've enabled debbuging in OpenELEC through SSH into my Raspberry Pi. I have no monitor connected and every time I check kodi.log I see that CEC is complaining about it. What can I do?

22:26:37 T:2954884160   ERROR: CecLogMessage - could not start CEC communications
22:26:37 T:2954884160   ERROR: OpenConnection - could not opening a connection to the CEC adapter
22:26:47 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:47 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:47 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 1)
22:26:48 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:48 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:48 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 2)
22:26:49 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:49 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:49 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 3)
22:26:50 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:50 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:50 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 4)
22:26:51 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:51 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:51 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 5)
22:26:52 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:52 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:52 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 6)
22:26:53 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:53 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:53 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 7)
22:26:54 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:54 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:54 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 8)
22:26:55 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:55 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:55 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 9)
22:26:56 T:2954884160   ERROR: CecLogMessage - RegisterLogicalAddress - vc_cec_set_logical_address(E) returned invalid arg (8)
22:26:56 T:2954884160   ERROR: CecLogMessage - Open - vc_cec could not be initialised
22:26:56 T:2954884160   ERROR: CecLogMessage - could not open a connection (try 10)
22:26:57 T:2954884160   ERROR: CecLogMessage - could not start CEC communications
22:26:57 T:2954884160   ERROR: OpenConnection - could not opening a connection to the CEC adapter
  • Ok, I've solved it by editing config.txt and enabling hdmi_force_hotplug, however I can't remount /flash to read-only. I do mount /flash -o remount,ro then reboot and it is still writable. – whitenoisedb Feb 5 '15 at 23:27
  • try mount -o remount,ro /flash – screaming drills Jun 25 '18 at 15:06
2

From Disable CEC:

http://elinux.org/RPiconfig

Add hdmi_ignore_cec=1 to /boot/config.txt

I thought CEC doesn't do anything anyway unless running something like XBMC. But I have both a Pi and Ubuntu Linux on my desktop PC connected to my HDTV, so the Pi does not actually turn my TV on/off. And the only time my Pi pays any attention to my TV remote is when running Raspbmc.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.