I have a TL-WN725N v2 WiFi adapter and I can't get it working on Raspberry Pi running Arch Linux. Linux kernel version is 3.18.5-1-ARCH #1.

Some time ago, to make this adapter working, it was necessary to compile driver for every kernel version. Now I found that not so long ago the driver was included into kernel. I have tested it on Raspbian and it works. However I can't say the same about Arch Linux.

I'm not sure how to troubleshoot it, but here's what I tried to look at so far:

  • ifconfig

    eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500  
        ether b8:27:eb:1b:a5:93  txqueuelen 1000  (Ethernet)  
        RX packets 0  bytes 0 (0.0 B)  
        RX errors 0  dropped 0  overruns 0  frame 0  
        TX packets 0  bytes 0 (0.0 B)  
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0  
    lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536  
        inet  netmask  
        inet6 ::1  prefixlen 128  scopeid 0x10<host>  
        loop  txqueuelen 0  (Local Loopback)  
        RX packets 960  bytes 75840 (74.0 KiB)    
        RX errors 0  dropped 0  overruns 0  frame 0  
        TX packets 960  bytes 75840 (74.0 KiB)  
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0    

No needed wlan0 interface.

  • ip link

    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN mode DEFAULT group default   
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00  
    2: ifb0: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 32  
    link/ether 82:7b:8e:6f:66:f0 brd ff:ff:ff:ff:ff:ff  
    3: ifb1: <BROADCAST,NOARP> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 32  
    link/ether 6e:7a:fd:64:91:45 brd ff:ff:ff:ff:ff:ff  
    4: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN mode DEFAULT group default qlen 1000  
    link/ether b8:27:eb:1b:a5:93 brd ff:ff:ff:ff:ff:ff  
    5: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN mode DEFAULT group default qlen 1000  
    link/ether c0:4a:00:12:d1:2d brd ff:ff:ff:ff:ff:ff    

However wlan0 is listed here. If I try ip link set wlan0 up it says IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready .

  • lsusb

    Bus 001 Device 005: ID 0bda:8179 Realtek Semiconductor Corp. RTL8188EUS 802.11n Wireless Network Adapter

  • lsmod

    Module                  Size  Used by  
    joydev                  9070  0   
    evdev                   9900  0   
    hid_logitech_dj        10218  0   
    r8188eu               430207  0   
    leds_gpio               3492  0   
    led_class               4066  1 leds_gpio  
    uio_pdrv_genirq         3238  0   
    uio                     8753  1 uio_pdrv_genirq    
    sch_fq_codel            7611  2   
    snd_bcm2835            19740  0   
    snd_pcm                86628  1 snd_bcm283  
    snd_timer              20697  1 snd_pcm  
    snd                    61799  3 snd_bcm2835,snd_timer,snd_pcm  
    bcm2708_rng             1044  0   
    rng_core                5666  1 bcm2708_rng  
    ipv6                  327644  14     

Here, I believe, it shows that r8188eu (the driver for the adapter) is there.

Still there's no connectivity and no blinking blue light.

I would highly appreciate any help or directions how to tackle this problem.

4 Answers 4


None of this is necessary anymore.

I have an old model B and had all the problems with the TP-Link 725N and the RTL8188 drivers years ago. I got the same problem when I updated.

However, today I just reflashed my SD Card with Raspbian Stretch and the old WiFi dongle worked out of the box: no config required at all.


For others, who stumbled on this question, try this https://bbs.archlinux.org/viewtopic.php?id=192404.

The threads, mentions to use packer to install necessary module.

packer -Ss dkms-8188eu # search for driver
packer -S dkms-8188eu # install the driver

This might also come in handy when using USB Dongles with certain drivers, where making the module available on during boot process can help set up the link for wlan0. I tried this, however on Raspbian Jessie with a LogiLink WL0145N WLAN which also has the r8188eu driver on it.

Inside the /etc/modules file add r8188eu (also add ipv6 if needed in the same file) and then reboot. This might do make the module available for the WLAN dongle and making the link ready for usage.


I am also using this Wi-Fi adapter. I have some problems with this Wi-Fi adapter on my Raspbian Wheezy. After installing the TP-Link drivers on my Raspbian wheezy it become working. But on Raspbian Jessie we do not want to install TP-Link drivers. However we can use following commands to install driver software:

$ curl -s https://dl.dropboxusercontent.com/u/80256631/install-8188eu.tgz | tar xz
$ ./install-8188eu.sh -l
$ uname -a
$ ./install-8188eu.sh -k #xxx

Then reboot the Pi and check your TP-Link Wi-Fi adaptor's indication LED is blinking or not.

Reference: thepizzy.net

But I found that the curl command for that Dropbox content not working nowadays. Since they removes that from Dropbox. But I saved this file on my Google drive. I don't know is it working however I am sharing TP-link driver software.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.