0

Currently my raspberry pi, running Raspbian, won't fully boot up because its getting stuck 5 seconds into boot at udevd[107] starting version 175

Everything was running smoothly until I installed upstart to run my node server on the pi.

I ran these commands:

sudo apt-get install upstart

Once it was installed I was getting Unable To Connect To Upstart: Failed To Connect To Socket /Com/Ubuntu/Upstart: Connection Refused error which I solved by running:

sudo dpkg-divert --local --rename --add /sbin/initctl
ln -s /bin/true /sbin/initctl

After running those commands I rebooted and got stuck at boot at udevd. Any advice other than flashing new raspbian image?

  • Anything interesting above the last line? Maybe a screenshot (as in a photo of the screen :) could help? Also: which OS? The link you followed perhaps does not apply to your case, it seems hackish to me. – Frepa Feb 10 '15 at 9:43
  • the comments against that blog post for the fix complain that "the distro don't boot afterwards" so I suggest you revert your change and try something else. – rob Feb 10 '15 at 11:04
  • @rob I just read that. If I mount the sdcard from the raspberry pi on my mac could I link /sbin/initctl to /sbin/initctl.distrib from terminal? – Nick Feb 10 '15 at 14:37
  • I cannot see why not – rob Feb 10 '15 at 15:00
  • So I mounted the sdcard and linked that file to no avail. Any idea how can i relink the file that upstart changes? – Nick Feb 12 '15 at 18:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.