28

I just got my new Raspberry Pi 2 and installed RASPBIAN using NOOBs.

On start up I get this error. Its in a message box in the middle of the screen. If I hit ok the GUI seems to work find anyway.

GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: Cannot determine user of subject

I have looked around and for similar errors people suggest this to fix the problem

Preferences->Desktop Session Settings" and un-check "PolicyKit Authentication Agent"

However there is no "Preferences->Desktop Session Settings" that I can find.

Does anyone else with a raspberry Pi 2 have this problem with a fresh install of RASPBIAN? Or do you know where I can find these Preferences.

Thanks

  • Same here. Two units, both gave the same error message on first use of startx. Both do not show the error on subsequent starts. – user26939 Feb 12 '15 at 17:11
26
  1. Open LXTerminal.
  2. Type lxsession-edit to open Desktop Session Settings dialog box.
  3. Uncheck LXPolKit.
  4. Click OK.
  5. Reboot.

If no LXPolKit option then try this :

  1. Open Terminal.
  2. Type sudo leafpad /etc/xdg/autostart/lxpolkit.desktop
  3. Add the text LXDE to the line NotShownIn
  4. The line should read: NotShowIn=GNOME;KDE;LXDE. Save the file afterwards.

The lx policy kit still runs, it just doesn't report errors ...

  • Thanks skipmonkey that was the window I was looking for :) – CHammond Feb 12 '15 at 23:54
  • I started seeing this error after installing xrdp, this advice fixed it though. Thanks ^_^ – PiBorg Mar 25 '15 at 17:04
  • I don't have the LXPolKit item in that window. I show Blueman Applet, GSettings Data Conversion, LXInput autostart, lxkeymap, and Notification Daemon. Everything except GSettings Data Conversion is checked. Any other suggestions? Thanks. – Stickhog Dec 11 '15 at 18:20
  • in my system i didn't see the policykit setting in Desktop Session Settings. so only after installing this package "policykit-1-gnome" i saw it and could disable it. – Asaf Magen Mar 19 '16 at 20:23

protected by Community Mar 25 '15 at 15:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.