18

I tried this tutorial on the latest debian wheezy (2015-01-31) http://www.lukebrowning.com/hardware/raspberry-pi/touch-screen-chromium-kiosk-on-the-raspberry-pi/ but its not working anymore... (If I made the same thing on an older debian wheezy (2014-06). Its working fine. What I should modify?

2
  • have you looked at these raspberrypi.stackexchange.com/search?q=kiosk also what specifically isn't working Feb 11 '15 at 21:55
  • 1
    Yes, first I red theese questions but too old question and didnt solved my problem. I think something changed with in the new debian wheezy, but iam not sure
    – szuniverse
    Feb 11 '15 at 21:59
34

It appears there is now a different autostart file to use located in /etc/xdg/lxsession/LXDE-pi/autostart

To get Chromium to autostart follow these instructions

  1. Type

    sudo nano /etc/xdg/lxsession/LXDE-pi/autostart"
    
  2. Add the following line:

    /usr/bin/chromium --kiosk --ignore-certificate-errors --disable-restore-session-state "http://www.domain.com"
    
  3. Press Ctrl+x

  4. Press y
  5. Press Enter

Worked for me!

4
  • 2
    On Raspbian Jessie add this line @/usr/bin/chromium --kiosk --ignore-certificate-errors --disable-restore-session-state "http://www.domain.com" to /home/pi/.config/lxsession/LXDE-pi/autostart instead
    – czerasz
    Jul 31 '16 at 0:52
  • 7
    As I understand it, Chromium is now Chromium Browser so you need @/usr/bin/chromium-browser --kiosk --disable-restore-session-state www.domain.com in the /home/pi/.config/lxsession/LXDE-pi/autostart. I also had to remove the quotes and http to get it to work.
    – Pete
    Nov 7 '16 at 16:16
  • 1
    The --ignore-certificate-errors also produced warnings when Chromium opened up. Otherwise, works like a charm. Aug 3 '17 at 12:47
  • Thank you so much for the --disable-restore-session-state flag. Was looking for that for ages!
    – Sebastian
    Sep 9 at 6:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.