0

My Raspberry Pi B+ is connected to my network Wi-Fi through a Belkin F5D7050 USB dongle. The connection works perfectly for about 10 minutes or more, but after this time period my Raspberry Pi becomes unreachable. I followed this guide, but nothing is changed.

How can I fix this problem?

  • Is it always exactly the same amount of time before the connection dies? Does the Pi still operated locally, monitor keyboard etc? Is this Raspbian OS and have you updated both the distro and the firmware to the latest? – rob Feb 12 '15 at 9:26
  • Hi rob, thx for your answer. The time before dies it is not the same. My raspberry runs a webserver written in nodejs. Yes, my raspberry is updated. – Antonio Feb 12 '15 at 9:41
1

Based on the number of related issues and even though this is a Raspberry Pi B+ I am going to have to say this is highly likely related to power issues.

Power issues on the Raspberry Pi are often not consistent, for example, the Raspberry Pi will operate without issue for minutes, hours, days, etc. Before failing.

Please unplug everything and check the power test points.

It's also worth noting that USB power plugs often fail to supply the require 5 V EVEN if they are rated as such. If the PSU is providing the correct voltage the cable may be losing enough to cause the Raspberry Pi problems (I have had direct experience of this, do not buy cheap USB cables).

My own experiments showed that a difference of just 0.15 V (average) was enough to cause sporadic stability issues, that would affect the image on the SD card.

The PiHUB (again, in my experience) seems to offer superior power consistency and improved stability.

0

It sounds like the USB dongle is 'going to sleep'. Set up a 'cron' job to 'poke' the USB connected network (for example, 'ping 192.168.0.1' (or whatver your router ('gateway') IP address is) every five minutes or so and see if that fixes it.

If not, then it is possible you have a power supply (voltage) issue, however I would expect that to show up during actual usage (lots of power being used) rather than when idle (less power used)...

0

I solved my problem. I tried to use a USB hub with an external power supply, but the problem persists.

After, with the iwconfig command (iwconfig wlan0) I found the solution: Before:

      `wlan0    IEEE 802.11bg  ESSID:"<myESSID>"
      Mode:Managed  Frequency:2.412 GHz  Access Point: 0A:A1:51:B7:9D:4A
      Bit Rate=48 Mb/s   Tx-Power=20 dBm
      Retry  long limit:7   RTS thr:off   Fragment thr:off
      Power Management:on
      Link Quality=44/70  Signal level=-66 dBm
      Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
      Tx excessive retries:0  Invalid misc:6953   Missed beacon:0`

As you can see the power managment is ON! Through the interfaces file you can disable that option adding this line:

wireless-power off

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.