2

How do I play a live adaptive HLS stream with the .m3u8 extension at boot of the Raspberry Pi?

Please share full code on how to do it.

1
  • i tried on rasbian with $ livestreame hlsvarient://ekonk...akamaihd../live/master.m3u8 --player omxplayer --fifo but omxplayer play only for 30second and exit auto maticall. what i want is it should play the asaptive bitrate stream with full screen after booting pi and never stop.
    – kalpesh
    Feb 15, 2015 at 8:32

1 Answer 1

5

I had the same problem but only it would sometime play 30s, sometime 90s but not more. It was omxplayer which exited. I added the option --timeout 20 to omxplayer so the command line looks like this:

livestreamer hlsvarient://ekonk...akamaihd../live/master.m3u8 --player "omxplayer --timeout 20" --fifo 

In fact as HLS works with 10s chunks, the player needs to retrieve regularly chunks from the origin, and it seems that sometimes it takes more than 10s, so increasing the timeout helps. You may increase the timeout if needed. Hope this helps.

-- Richard

1
  • This is absolutely incredible that this is the answer and yet so hard to find. I have seen many people asking about this on the webs. Really this is such a common problem that I think the default should be changed. Sep 5, 2017 at 22:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.