1

I'm running raspbian on an RPi2B and I'm trying to mount a network drive. I've tried the following:

sudo mount -t cifs -o username=admin,password=passwd //192.168.1.1/root /mnt/myshare

But I keep getting permission denied error.

I can access this share fine on my macbook pro with the same credentials so I don't understand what's going on.

I have dashes (-) in my password so I tried enclosing it in quotes, escaping the dashes etc. but nothing worked.

Any help would be appreciated!

  • Although the commandline environments are similar in overall concept, this goal is at a level where should probably not expect the method of doing this on a Linux system to be exactly the same as on OSX. Have you tried reading up on recommended procedures for doing this on Linux in general? – Chris Stratton Feb 14 '15 at 22:57
  • @ChrisStratton Actually I mounted the share in finder not in terminal. I'm a linux newbie so I got the command from a google search. I've tried many variations on it but all have yielded the same result. I came across one post which led me to believe that it could be to do with the encryption type used but I don't know how to check the encryption type or how to change it... – doovers Feb 14 '15 at 23:00
  • You might do better on unix.stackexchange.com - this would only be a pi issue to the extent that there would need to be pi version of whatever cifs packages are necessary. – Chris Stratton Feb 15 '15 at 0:26
1

Try adding sec=ntlm to the options so that in your example the command would read

sudo mount -t cifs -o sec=ntlm,username=admin,password=passwd //192.168.1.1/root /mnt/myshare

KenR

  • That gives me: mount error(11): Resource temporarily unavailable – doovers Feb 15 '15 at 21:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.