1

Step 1: Put latest Raspbian image (2015-01-31-raspbian.img) on compatible (according to http://elinux.org/RPi_SD_cards) Micro SD card

Step 2: Boot Raspberry Pi, ssh into it, expand filesystem, reboot

Step 3: apt-get update/upgrade, rpi-update, reboot

Step 4: Kernel Panic on boot

Kernel Panic

I'm using a 12W iPad charger that outputs 5.2V and 2.4A. The only things plugged into the Pi are the power supply, the screen and the SD card.

This happened four times, each time after rebooting the Pi a few times. Every time it happens, I have to reflash the SD card. Is my Pi just broken?

Edit: After reflashing the SD card for the tenth time and trying the third power supply, I've concluded that the power supply is not the culprit.

Edit 2: Turns out it was the card (a Sony Micro SD, if anyone's interested). After trying a spare SanDisk 16 GB Micro SD, which worked flawlessly, I bought a SanDisk 64 GB Micro SD and copied the 16 GB card's content over. One filesystem expansion and several app installations and reboots later, everything's still working. The Sony card itself seems to be in perfect working order, it's just that the Pi refuses to boot with it.

  • Are you shutting down properly or just yanking the cord? – goldilocks Feb 15 '15 at 18:30
  • I would assume that sudo reboot makes the Pi shut down properly. After the kernel panic, I obviously have to yank the cord. – Peter W. Feb 15 '15 at 20:11
  • sudo reboot will make RPi reboot. use sudo shutdown -h now for safe shutdown. And after black screen and activity led not lighting any more you can yank the cord. – Bungee75 Jan 23 '16 at 16:15
  • Well yes, that's why it's called reboot. What I meant was that it shuts the Pi down properly first, as opposed to pulling the power cord. – Peter W. Jan 26 '16 at 13:51
1

Its your power supply. I had two model B's so when my 2 came in I used one of their supplies (supply came with a kit) and I have had no problems.

Like you I expanded and rebooted, but then I moved my file system to USB and then did upgrade, dist-upgrade, rpi-update.

So yeah, our setups are different, but the power supply I'm using (and is the appropriate supply) is DC 5v 1500mA (1.5A)

Using the wrong supply could cause random writes to SD and as your panic states, it can't read a block.

I'm not an electrical guy, so I'm not sure if your cord will eventually fry something, but if you have a USB drive you might get away with putting on USB and then do your updates, but really, you should just buy the appropriate supply off Amazon or your site of choice. If you're in the states and still have a radio shack in area, they may have one. One in my area caries pi supplies.

Edit: plus even with the right supply, I would still say put the file system on USB. Better performance (IMO) and you don't have to worry about SD wear and tare.

Edit 2: Not sure if it would even matter, but we're it me, I would probably expand file system and reboot, then rpi-update and reboot, then apt-get (if boots) while trying to troubleshoot this issue, but again, I really think it is your power supply giving you the trouble.

  • What power supply would you recommend? I want to use the Pi with a WiFi stick later on, so I figured the iPad charger would be good enough. – Peter W. Feb 15 '15 at 20:14
  • Link feel free to shop around. Like I said, if your in the states and in area that still has radioshack, they may have one. Main thing is that it's DC 5v 1500mA (1.5A) – geoffmcc Feb 15 '15 at 20:17
  • Tried a few other power supplies and concluded that it's not the power supply. Something else is wrong with my Pi and the cryptic error messages on boot are not helping. – Peter W. Feb 16 '15 at 12:08
  • Did any of them match the above mentioned specs? – geoffmcc Feb 16 '15 at 13:11
  • One did, the others were either 5V 1A or 5.2V 2.4A ones. – Peter W. Feb 16 '15 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.