2

I am working on getting my very very very cheap chines display working. As far as I can tell, its a TFT 1.44" 128x128 SPI display (printed on the board) - and the internet seems to direct me towards the ILI9163C driver. However, all I get is white screen an no response.

What I have done so far

I have set up the wiring from my Raspberry Pi 2, to the display (through a breadboard) like this:

===== DISPLAY =====   == GPIO ==
LED     (BACKLIGHT)   3.3v (pin 1)
SCK     (SCLK)        pin 23
SDA     (MOSI)        pin 19
A0      (DC)          pin 16
RESET   (RESET)       pin 18
CS      (CS)          pin 22
GND     (GND)         GND (pin 9)
VCC     (VCC)         3.3v (pin 17 - could probably be shared pin 1?)

However with this setup, the screen is blank white. If i decouple pin 17 (VCC) nothing happens, however decoupling pin 1 (LED) it goes into unpowered blank screen (obvious). However if i couple VCC and LED together, the screen goes "black but with power" (as in the color 0x0).

I am using the latest Wheezy Raspbian. Raspi-Config have SPI enabled. I have an /dev/spidev0.0 and /dev/spidev0.1. I have loaded spi_bcm2708, as listet by lsmod.

I have tried loads and loads of different libraries and python scripts, but none of them gets any kind of response or results on the screen. The famous "spidev_test" that I downloaded here: https://www.kernel.org/doc/Documentation/spi/spidev_test.c does not fail, however it results in an outputtet array of only zeroes:

spi mode: 0
bits per word: 8
max speed: 500000 Hz (500 KHz)

00 00 00 00 00 00 
00 00 00 00 00 00 
00 00 00 00 00 00 
00 00 00 00 00 00 
00 00 00 00 00 00 
00 00 00 00 00 00 
00 00 

I am looking for any kind of way for communicating with my TFT screen - fast or not fast - with my current wiring or a new wiring. I am obviously doing something wrong, and I suspect either the GPIO or my handling of the Raspberry Pi - any help would be appreciated !

  • hi its a st7735 driver that you need,trust me – user38241 Dec 14 '15 at 17:03
0

first you need to make sure SPI is enabled.

run

sudo raspi-config 

and go to advanced options to enable SPI, reboot

EDIT: NVM, just saw where you have this enabled. I would look through Adafruit's python librarys for their SPI screens. There are a lot of similarities between most drivers, you just need to know what format it wants the info.

https://learn.adafruit.com/user-space-spi-tft-python-library-ili9341-2-8/overview

  • thanks for your comment. I will mark it as an answer - as this would be the correct way to go about this. I "solved" my issue by.. well, leaving the Pi off for a day, turning it back on (undoubtedly a few minutes could have fixed it) - appeared the 1.44" was shocked by my ruthless polling. Also, the device seems to be ReadOnly - so spidev_test would never have returned anything anyway - and even worse, the device is falsely wired, to think its 160x128. I suggest buying the black board version for everyone else :) – Mads Soransen Feb 24 '15 at 12:04
  • Glad you were able to get it working, sorry I was not able to help more. – jslay Feb 24 '15 at 16:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.