3

I am having an issue with my external hard drive and it is quite annoying.

So, I purchased the Samsung M3, for the sole purpose of acting as a mass storage device for my Raspberry Pi. Lovely.

I originally had it mounted with ntfs-3g, that was REALLY slow and performance was awful. I reformatted the drive with an ext4 filesystem, mounted it with noatime. Cool, everything is working.

Except, the drive does not spin down. It is constantly spinning, 24/7. This did not happen when it was mounted with ntfs-3g, but ever since switching to ext4 it has just not stopped spinning.

I have attempted the following to fix it:

sudo hdparm -y /dev/sda - any hdparm command returns

/dev/sda: issuing standby command SG_IO: bad/missing sense data, sb[]: 70 00 01 00 00 00 00 0a 00 00 00 00 00 1d 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00 00

I then decided to try sudo udisks --set-spindown /dev/sda --spindown-timeout 20, which returned Setting spindown failed: Cannot spindown device.

I just can't seem to get it working, even though it was perfectly fine with ntfs-3g.

Any help would be very much appreciated.

2

I should have posted this months ago, this is how I resolved it.

  • Created a folder, applied the appropriate permissions
  • Edited /etc/fstab
  • Added the following:

    /dev/sda1   /media/usbhdd   ext4   defaults,noatime   0 0
    
  • Save, reboot

And everything was working perfectly. Hope it helps people

*Where /media/usbhdd is the folder you added

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.