3

(Using ubuntu 14 on a laptop) I followed this guide to set up my wifi by sshing into the pi via ethernet. I checked my routers networks settings and it showed two ip addresses from the pi, and I could ssh into the wireless address without a problem.

When I unlplugged the ethernet and restarted the pi the wifi address does not show up, and I can't ssh in.

I tried restarting it with and without ethernet with the same results. whats happening?

Here is my interfaces file:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

iface wlan0 inet dhcp
wpa-ssid "Patty likes oldman"
wpa-psk "analrapist"
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

Here is my wpa_supplicant.conf file:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="Patty like oldman"
psk="analrapist"

# Protocol type can be: RSN (for WP2) and WPA (for WPA1)
proto=WPA

# Key management type can be: WPA-PSK or WPA-EAP (Pre-Shared or Enterprise)
key_mgmt=WPA-PSK

# Pairwise can be CCMP or TKIP (for WPA2 or WPA1)
pairwise=TKIP

#Authorization option should be OPEN for both WPA1/WPA2 (in less commonly used $
auth_alg=OPEN
}
  • Without knowing what you did noone can say. There are hundreds of guides on setting up IP on the Pi, most wrong. – Milliways Feb 27 '15 at 1:08
  • added the guide used – tkelly003 Feb 27 '15 at 3:28
  • what do you mean by turn on? power turns on or accessibility over network? – askmish Feb 27 '15 at 4:11
  • it flashes blue when it is working and accessible over the network, it only does this when ethernet is also plugged in – tkelly003 Feb 27 '15 at 4:15
1

This applies to Raspbian Wheezy prior to 2015-05-05 for later (and Jessie) See How do I set up networking/WiFi/Static IP

This SHOULD work, but without seeing your /etc/network/interfaces it is hard to know.

I do not think this is the best option. I suggest /etc/network/interfaces should contain

allow-hotplug wlan0
auto wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

iface default inet dhcp

wpa-roam will keep trying to reconnect when it finds no wired network.

wpa-conf option will not keep reconnecting.

It is difficult to find the documentation for these commands.

  • 1
    so I shouldn't put the password ssid and psk in the interfaces file? will it just get them from wpa_supplicant.conf? – tkelly003 Feb 27 '15 at 4:04
  • There are many ways to do this. Anyone can read /etc/network/interfaces so this is a security risk. In addition you can put many different networks in wpa_supplicant.conf – Milliways Feb 27 '15 at 4:17
  • this doesn't seem to be working, I've added the related files to my question – tkelly003 Feb 27 '15 at 4:30
  • You didn't setup as above. I particular iface wlan0 inet manual. Frankly most people who try to set these up manually get it wrong. The easiest and most reliable way to set up initially is with a monitor attached to the Pi, using the GUI setup utility. After this you can use ssh. – Milliways Feb 27 '15 at 5:04
  • It still doesnt work with this change. Unfortunately I don't have a monitor to use with it. I can use a remote desktop with ethernet though, where do I find the set up itility? – tkelly003 Feb 27 '15 at 5:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.