2

Raspberry Pi Model B

  • GEEETECH Arduino GPRS Shield V1.0
    (bought from: bit.ly/1G0KYR7)

  • ^ Similar somewhat to:
    Seeed's GPRS Shield V1.0 | Link: seeedstudio.com/wiki/GPRS_Shield_V1.0
    (has more information and schematics at the bottom, visually looks the same)


Some questions about what and how should i use:

  • Serial Port Select: SW / HW ?
  • Power Select:   Xduino / Ext ?
  • GND: where to connect the ground ?

  • SIM900 UART (2V8) - should i use the direct connection ?
    (^ tried with some success, but not sure how safe it is)
    (jumper should be placed in the middle, Ext. 5VDC from the power jack)


How to connect and set this up?
I've found a topic with some information, but i didn't understand the bottom line.
www.geeetech.com/forum/viewtopic.php?f=9&t=11169

"..The SIM900 GSM / GPRS Shield is installed the voltage level converter,you can connect SIM900 GSM / GPRS Shield and Raspberry Pi (RPi) from serial interface UART directly."

Pi <-> GSM Shield. What-to-Where?


Hope someone can help a newbie here :)


P.S:

Turning off the UART functioning as a serial console:
I've made the necessary changes for using the serial port (ttyAMA0)
by editing '/boot/cmdline.txt' and '/etc/inittab'.
Confirmed that Pi's UART is working by connecting together TX/RX Pins (GPIO 14/15)
and using minicom to type and receive what I've typed.

  • My test code (pySerial API): gist.github.com/gOmp/ca6a2a734ab5a3b521fe – Michael Sh. Feb 27 '15 at 18:45
  • Out of curiosity - assuming you're still out there - how did you get the uart pins to work? I tried moving the jumpers and connecting a 3.3v ftdi to tx/rx/gnd but didn't have any luck. I confirmed the modem is working with the arduino passthrough sketch. – Scott Wood Apr 26 '17 at 14:39
  • @ScottWood , It's been awhile and i don't have this setup anymore, but as i can recall, I think, there's a mosfet convertor of the tx/rx to 5v, as the sim900 stated as using a 2V8. I've used external 5V power supply on EXT_pwr. A single vertical jumper in the middle for the UART of the SIM900. GND/TX/RX to the pi. uploaded some old photos i've found imgur.com/a/oWEUe hope it would help, GL – Michael Sh. Apr 29 '17 at 12:18
  • Hmmm, I tried putting external 5v power to multiple power pins (the 5v one on the uart area, the arduino pin that is normally vcc in the arduino 5v pins, etc) and never could seem to get anything out that uart bus – Scott Wood May 8 '17 at 18:22
  • I've used the setup i mentioned above, as best as i can remember, I've used a 5V External Power Supply using the power jack, maybe it's a current issue, when you connecting to a 5V pin, maybe there's not enough current. – Michael Sh. May 9 '17 at 21:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.