3

To configure audio of soundcard I did the following settings:

sudo nano /etc/modprobe.d/alsa-base.conf

I commented options snd-usb-audio index=-2

and added options snd_bcm2835 index=1

so speaker was properly working with usb sound card

now for microphone configuration I went to

sudo nano /etc/asound.conf

and did the following changes:

pcm.!default {
    type plug
    slave {
        pcm "hw:1,0"
    }
}

ctl.!default {
    type hw
    card 1
}

using arecord only noise is recorded and also i am not able to play files through speakers.

I am using Storite 7.1 Channel USB External Sound Card Audio Adapter With Mic and r-pi B+ model

  • Have you looked at this computers.tutsplus.com/articles/…? – Steve Robillard Mar 1 '15 at 7:03
  • yup i have looked upon this site. but changing in sudo nano /etc/modprobe.d/alsa-base.conf only configures audio part of usb not microfone and i need both – goodan Mar 1 '15 at 11:39
1

The trick is is in ~/.asoundrc

If you have already gone into /etc/modprobe.d/alsa-base.conf and changed options snd-usb-audio index=-2 to options snd-usb-audio index=0 then:

First:

sudo nano ~/.asoundrc

Second:

Add

pcm.!default {
    type hw
    card 0
}

ctl.!default {
    type hw
    card 0
}

Then save and reboot your Pi.

This works because when you add options snd-usb-audio index=0 to /etc/modprobe.d/alsa-base.conf it only sets your usb card at index 0, it doesn't enable it.

Cheers!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.