1

On the raspberry pi, using the internal sound card by default you can output audio from multiple programs simultaneously and it mixes them together.

Since switching to a USB soundcard (merely by commenting out the line "options snd-usb-audio index=-2") in /etc/modprobe.d/alsa-base.conf, I can play audio and control volumes perfectly well, but cannot play simultaneously from multiple programs.

After starting one (and getting audio out) and then starting another, I get "audio open error: Device or resource busy"

Is there a way to re-enable this functionality? I am using a Griffin iMic USB sound card.

  • options snd-usb-audio index=-2keeps snd-usb-audio from beeing loaded as first soundcard. with options snd_usb_audio index=-1 you can load your usb sound card as default. But as far as i now, alsa cant mix. how you was mix your sound before using an usb device? – Joe Platano Mar 2 '15 at 12:40
  • In theory, dmix should be enabled by default. Did you (or Raspbian) change the definition of the default device? – CL. Mar 2 '15 at 13:57
  • As far as I know, checking in .asoundrc and /etc/asound.conf, there doesn't seem to be any definition for the default device... When I output using aplay though it does come out of the speakers, which seems to indicate it knows where the sound card is. Could it be that I have to write a dmix definition into .asoundrc or /etc/asound.conf? – Josh Mar 3 '15 at 1:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.