1

I have a Raspberry Pi 2 that works great until I try connecting a breadboard to it via a 40-pin ribbon cable and GPIO-to-breadboard interface board. Whenever the board is connected to the pi, the pi ceases to run. No lights on the leds, as if there is no power going to the device.

Trying to isolate the problem, I've made the following observations:

  1. If I create a simple led circuit on the breadboard and power it with wires going directly from the GPIO pins to the circuit, there are no problems.
  2. If I connect the ribbon cable to the pi and try powering the led test circuit from the 3.3v pin and ground, there are no problems.
  3. If I connect the GPIO-to-Breadboard interface, and try powering the test circuit from the +/- leads on the interface, there are no problems.
  4. As soon as I plug the GPIO-to-Breadboard interface in to the breadboard, blammo, no power to the raspberry pi or to the breadboard.

I am using the components included in the canakit starter set: http://www.canakit.com/raspberry-pi-starter-ultimate-kit.html

Am I missing something?

  • 1
    Looks like you're having some shortcuts in the breadboard when you plug the interface. If you have a multimeter you could check that - plug only the interface, without raspberrypi and look for shortcuts on the pins. If you don't have multimeter you should definitely buy one but before you do that you can make yourself continuity tester with the circuit from point 1 + some wires. – Krzysztof Adamski Mar 5 '15 at 19:36
  • 2
    Usually problems like this are because the two ends connected by the ribbon cable are not keyed. One end is plugged in back to front. – joan Mar 5 '15 at 20:22
  • Thanks, I tried reversing the connection with no luck. Am I looking for a problem in the breadboard or the interface with the multimeter? I did notice some damage to the breadboard when I opened the package, it almost looks like some of the contacts aren't lining up with the holes. – New2RPi Mar 6 '15 at 20:51
3

As they say in the auto industry: "A'yup, there's your problem!"

Looks like the breadboard came shipped misassembled. The connections were jammed into the wrong rail. I removed the sticky back, pulled out and reset the connectors in their own tracks and everything seems to be working fine now.

breadboard assembly

1

Here's how you want that cable and breakout aligned:

enter image description here

Red line at top corner of the pi with cable facing out to red line on the "5V" side of the breakout with the cable facing back.

  • Thanks, but I have tried this configuration as well as the reverse, same problem either way. – New2RPi Mar 6 '15 at 20:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.