I'm trying to set up my new RPI2 as a hub for my home automation projects. I am new to linux so please bear with me if this is a simple thing, I couldn't find a solution after a day of troubleshooting. Problem is, I've been trying to compile PulseAudio-raop2 to stream music to my AirPort Express. It compiles, but after running installing and running, it complains the following.

pulseaudio: symbol lookup error: pulseaudio: undefined symbol: pa_dbus_connection_unref

As for the installation, I just do the following:

sudo ./bootstrap
sudo make
sudo make install

I figure this is some kind of linking error though I have no idea how to solve this or even begin to search for the issue.

Here is the fork I am trying to install: https://github.com/hfujita/pulseaudio-raop2. I am running the suggested version of Raspbian from the official Raspberry site.

  • Unless you understand what you are doing it is sensible to only use software from the standard repositories. Why do you need this variant?
    – joan
    Mar 7, 2015 at 14:30
  • I need it to get AirPlay streaming support for my Raspberry's audio, as it is quite a distance away from my speakers. I'm actually trying to follow a guide posted here but it doesn't really work as described: raspberrypi.stackexchange.com/questions/5508/…. I tried the standard pulseaudio-module-raop-discover but it resulted in horrible stuttering when streaming the music. My AirPort Express is quite new so I figured it might make sense to try the new one as it provides support for the new AirPlay.
    – Jake
    Mar 7, 2015 at 14:38
  • It probably installed some libraries. Did you run ldconfig afterward? Check the executable with ldd (e.g. ldd /usr/local/bin/pulseaudio) to make sure everything its linked to is actually found by the linker.
    – goldilocks
    Mar 7, 2015 at 15:48
  • I did run ldconfig. I tried ldd and it doesn't seem to list any errors, just a bunch of different libraries. Here's the output: ldd output
    – Jake
    Mar 8, 2015 at 11:05


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.