2

Hi I bought this Comfast Wifi Adapter WU810n and came to know that it's not supported by raspbian directly. So I did follow http://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371 and get it working. But yesterday I flashed my sd-card with the lastest raspbian version and now when I run lsusb it doesn't show Realtek.

pi@raspberrypi ~ $ lsusb 
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.

When I run dmesg this is the output I get :

[139.747787] usb 1-1.2: new high-speed USB device number 4 using dwc_otg
[  139.849099] usb 1-1.2: New USB device found, idVendor=0bda, idProduct=8179
[  139.849142] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  139.849161] usb 1-1.2: Product: 802.11n NIC
[  139.849178] usb 1-1.2: Manufacturer: Realtek
[  139.849194] usb 1-1.2: SerialNumber: 00F1408816F7
[  139.929687] r8188eu: module is from the staging directory, the quality is unknown, you have been warned.
[  139.948403] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_UNKNOWN_CUT(10)_1T1R_RomVer(0)
[  139.992479] usbcore: registered new interface driver r8188eu
[  140.213122] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2
[  140.213169] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available
[  140.213192] MAC Address = 00:f1:40:88:16:f7
[  140.285819] usb 1-1.2: USB disconnect, device number 4
[  140.286600] R8188EU: ERROR indicate disassoc
  • I'm also facing this issue. Lsusb does not detect my adapter – STEEL Apr 16 '15 at 12:16
  • "NOTE: the driver files for 3.18.xx+ and 3.18.xx-v7+ contain two additional files, install.sh and 8188eu.conf. Download the driver file selecting the right driver for your kernel version from the list above then to install the 3.18 drivers first untar the tar.gz driver file and then run the install.sh command.eg." – user1133275 Apr 18 '15 at 12:48
  • can u be more specific – STEEL Apr 20 '15 at 7:47
  • 1
    Did you notice that in the link you posted as part of your question there is a different driver file for every kerner version ? Did you consider that updating to latest raspbian could have update kernel to a possibly newer version ? Did you already try repeating the steps with the driver tar.gz file matching the output from 'uname -a' ? – koushik Jun 18 '15 at 18:33
2

If an adapter doesn't show up in lsusb that usually means that it needs firmware file(s) and your dmesg output proves that:

[  140.213122] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2
[  140.213169] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available

Installing the firmware-realtek package should fix that. Make sure you have non-free in your /etc/apt/sources.list file, otherwise it won't find it.

0

I had similar issue with external wifi dongle. Error found in logs /var/log/kern.log and other sys log files:

root@raspberrypi:/var/log# more /etc/debian_version
7.8
Jul  3 14:07:35 raspberrypi kernel: [  334.291672] usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Jul  3 14:07:35 raspberrypi kernel: [  334.291689] usb 1-1.2: Product: 802.11n NIC
Jul  3 14:07:35 raspberrypi kernel: [  334.291706] usb 1-1.2: Manufacturer: Realtek
Jul  3 14:07:35 raspberrypi kernel: [  334.293224] Chip Version Info: CHIP_8188E_Normal_Chip_TSMC_UNKNOWN_CUT(10)_1T1R_RomVer(0)
Jul  3 14:07:35 raspberrypi kernel: [  334.453224] r8188eu 1-1.2:1.0: Direct firmware load for rtlwifi/rtl8188eufw.bin failed with error -2
Jul  3 14:07:35 raspberrypi kernel: [  334.453258] r8188eu 1-1.2:1.0: Firmware rtlwifi/rtl8188eufw.bin not available
Jul  3 14:07:35 raspberrypi kernel: [  334.453274] MAC Address = <mac adddr>
Jul  3 14:07:35 raspberrypi kernel: [  334.468794] usb 1-1.2: USB disconnect, device number 5
Jul  3 14:07:35 raspberrypi kernel: [  334.469531] R8188EU: ERROR indicate disassoc
Jul  3 14:07:47 raspberrypi kernel: [  345.619686] nr_pdflush_threads exported in /proc is scheduled for removal

Solution was found at : Here

sudo wget https://github.com/lwfinger/rtl8188eu/raw/c83976d1dfb4793893158461430261562b3a5bf0/rtl8188eufw.bin  -O /lib/firmware/rtlwifi/rtl8188eufw.bin

Just replug the wifi device and it should start glowing! I tried multiple methods but didn't worked for me.

If above firmware change didn't help. Pls follow this . Means, you have to do config/setup required after firmware part is done ie setting up wpa_supplicant OR setting correct /etc/network/interfaces file. My file looks like:

root@raspberrypi:/var/log# cat /etc/network/interfaces
auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
auto wlan0

iface wlan0 inet dhcp
        wpa-ssid "SID_name"
        wpa-psk "your_password"

Good luck! If above didn't work for you, let me know in comments. :)

-1

Flashing the SD-Card may have un-done the changes you did. Follow the same instructions you did to get it working the first time.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.