2

I just upgraded my RPi B from wheezy to jessie. This worked fine so far. Only had some trouble with systemd, so I uninstalled it and switched back to sysvinit (I like it more anyways). Now I am on jessie, everything works as before, with one small but annoying difference:

The boot process takes around 20 to 30 seconds additionally (before it was like 10 seconds all together) on the step

Waiting for /dev to be fully populated

It switches to OK in the end and everything works, but since jessie it takes horribly long to succeed.

Additional information:

  • The Pi is running headless (SSH only, no display)
  • no USB device is attached (no WiFi dongle, no keyboard, no HDD, no whatsoever)
  • only the default stuff is mounted (SD card)

After googling a while I found out that it seems that /etc/udev is responsible for that, but I'm not sure what I have to look for. Especially, the config files in there are empty or "trivial" one-liners which I manually never touched (so I assume they are in the default state).

What device could cause this long pause on a plain Raspberry Pi? And how to speed it up again?

  • Did you have this problem before you switched back to SysV init? – goldilocks Mar 8 '15 at 17:57
  • @goldilocks Not sure. With systemd the boot was extremly slow anyways on several steps, it always bootet into emergency mode (for which I plugged a display and keyboard on, and uninstalled systemd, then removed display and keyboard again). I can't say if systemd was slow on this step as well. – Foo Bar Mar 8 '15 at 18:01
2

I had the same problem after upgrading to Raspbian Jessie and I solved it like this:

Edit /etc/udev/udev.conf and change from:

udev_log="info"

to

udev_log="err"

Worked for me.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.