I am trying to boot Arch Linux image. I've done everything according to Reinstall Manual and when I power up with created os on microSD card, the red and green LEDs are turned on, HDMI is dead, ethernet LEDS are dead. I am powering rPi from original Samsung power adapter (for cellphone), I've tested LAN cable, I've tested HDMI cable, still no activity. What am I missing? I have another rPi which is working just fine. If I put new microSD card into working rPi, I get same result as described. If I put the microSD from working rPi into testing one, it works like charm, so there are no hardware failures and neither power problems, because I tried with same Samsung adapter. What am I missing?

  • So what's on the card that works?
    – goldilocks
    Mar 8, 2015 at 17:53
  • @goldilocks I've downloaded ArchLinuxARM-rpi-latest.tar.gz from Arch Linux Site, created partition as in that html manual and uncompresed ArchLinuxARM-rpi-latest.tar.gz to microSD card. Mar 8, 2015 at 19:59
  • I meant "What's on the card that works?" although I guess it doesn't matter. Are you saying the green light comes on and stays on steady (i.e., never flashes)? If not, does it flash twice right away, and then come on and flicker? Describe it precisely.
    – goldilocks
    Mar 8, 2015 at 20:02
  • @goldilocks After I power up the rPi B+, RED and GREEN leds turn on and stay turned on, there is no flickering. Also, there is no activity at ethernet port (leds are turned off). Mar 8, 2015 at 20:06
  • 1
    Hmmm -- I noticed this with the Pi 2 today. Try it quick with HDMI unplugged and see if anything different happens.
    – goldilocks
    Mar 8, 2015 at 20:09

1 Answer 1


If the green light comes on and stays on steady, but if it only does this with one particular card and not another, there's perhaps something wrong with the card, such that there's no working MBR, or the card is in completely the wrong format.

It's not simply some corruption (unless it's in the first 1/2 kB), since in that case there would be some indication; the green light will flash in specific patterns when there is a bootloader/firmware/kernel problem.

The Arch page you linked seems to be for a generic ARM installation, which would probably result in "completely the wrong format". The pi has specific requirements, including a DOS FAT style first partition. Try following these instructions which is for prepping an SD card for the pi with Arch.

To check the MBR on linux, if the card is /dev/sdb (note, no partition number):

dd if=/dev/sdb of=mbr.test bs=512 count=1
file mbr.test

You should get:

testmbr: DOS/MBR boot sector; partition 1 ...etc.
  • The linke I gave are wrong instructions, the link you gave me are RIGHT instructions, it worked from 1st try! Mar 10, 2015 at 9:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.