1

I bought a nice small anonymous (no maker's name) 78 key wireless keyboard for my HDMIPi with RPi 2, and it works very well, except that I cannot discover which of the layouts listed in sudo raspi-config is the correct one to use. I have tried various combinations of keyboard and language in rspi-config but cannot get both " and \ to work at the same time.

It has the same layout and symbols on the keys as this one (the second key from the left in the bottom row is labelled 'Fn':

enter image description here

Please, has anyone else had, and solved, this problem?


Thanks for the comment @Steve Robillard. I am in the UK, with a recently acquired Raspberry 2, and used the keyboard, which is wireless, with its original dongle and no attempt to set it up, quite happily until I wanted to try out C programming with "Hello World!\n" and found I could not type the backward stroke. The key with the \ symbol produced a hash sign #.

These are the keys (in brackets) that give a different symbol from that printed on them as in the image: (shift+2) " (shift+3) £ (shift+comma) @ (backward stroke) # (shift+backward stroke) ~

I tried various settings, which I unfortunately did not record, but in none of them could I find one that allowed me to enter both the double quotation marks and the backward stroke in the same setting.

I didn't try the 101 key setting because this keyboard has only 78 keys, How would this be reconciled?

  • Have you tried 101 generic keyboard and en-us, this assumes you are in the US. If you are not in the US please edit your question and include your location, and what you mean (specifically) by " and \ not working. – Steve Robillard Mar 8 '15 at 20:19
1

In the absence of a more authoritative answer, this is my solution so far : using sudo raspi-config I have set the keyboard layout to Microsoft Office and US-English. At least, now, the keys produce on the screen the symbol that is printed on them, and both the " and \ keys do give those symbols. One final point, I did not see any instruction to do so, but I found I had to re-boot for these changes to take effect.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.