2

I use neo 6 ublox 6 GPS module. I choose to connect the GPS to the raspberry using a USB port. I followed these steps:

pi@raspberrypi ~ $ sudo cat /dev/ttyUSB0  
$GPRMC,144034.00,V,,,,,,,090315,,,N*75
$GPVTG,,,,,,,,,N*30
$GPGGA,144034.00,,,,,0,00,99.99,,,,,,*60
$GPGSA,A,1,,,,,,,,,,,,,99.99,99.99,99.99*30
$GPGSV,1,1,01,15,,,25*7B

sudo apt-get update
sudo apt-get install gpsd gpsd-clients
sudo dpkg-reconfigure gpsd   
start gpsd automatically: yes
Should gpsd handle attached USB receivers automatically: yes
Device the GPS receiver is attached to: <leave blank>
Options to gpsd: -n /dev/ttyUSB0
gpsd control socket path: <use default>

sudo gpsd /dev/ttyUSB0 -F /var/run/gpsd.sock
cgps -s
**NO FIX**

What should I do for NO FIX problem?

  • 1
    if you run cgps (without -s) do you get any data? If you only have a few satellites I think it reports NO FIX. Also use gpspipe. – rob Mar 9 '15 at 15:50
  • Does your GPS have a clear view of the sky? – Steve Robillard Mar 9 '15 at 16:22
  • @SteveRobillard Yes, I have a clear sky view. window ledge – gulyvz Mar 10 '15 at 7:14
  • @rob unfortunately i got no data when i tried cgps – gulyvz Mar 10 '15 at 7:15
  • cgps and gpspipe should both just show curated data in the same way as your cat command did. Only things I can suggest are update, reboot and try a powered USB hub. – rob Mar 10 '15 at 11:40
3

my GPS module is based on L80-39 chip, I've installed gpsd and gpsd-clients packages to drive this module, and reboot my Raspberry Pi. you can try those command as following:

sudo killall gpsd
sudo gpsd /dev/ttyUSB0 -F /var/run/gpsd.socket

or Edit /etc/default/gpsd file, input your device name and parameters:

enter image description here

sudo systemctl enable gpsd.socket
sudo systemctl start gpsd.socket 
sudo cgps -s

it may works. good luck. enter image description here

0

in my case it was only solvable by altering parameters in '/etc/default/gpsd' there you can set your /dev/ttyUSB0 for example and -n if the normal method does not work

0

Edit the file /etc/default/gpsd and add your serial port in DEVICES, like

DEVICES="/dev/ttyUSB0"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.