0

My Raspi Camera NoIR is designed to get pictures outdoor during the night from my house patio. I only get good pictures with the option -ex night otherwise it's quite black in spite of the infrared illuminator that I am also using.

Is that normal?

The main problem with using -ex nightis that moving objects or persons are blurred. Is there a better solution?

Is it possible to work with the -ss .. option to adjust the shutter speed instead?

I could not find any info about that?

  • Do you have a light meter? What do you mean by "powerful illuminator"? 1000 W halogen floodlight? A few 100 W incandescents? Remember that our eyes adjust to quite a range of light, so what may appear to you to be "almost as bright as day" may be very far from it. – goldilocks Mar 9 '15 at 15:19
  • Have you tested your camera with a infrared tv remote ? Just to make sure it functioning properly? – monojohnny Mar 9 '15 at 15:29
  • Powerfull illuminator...I mean an infra red illuminator. It's not supposed to be visible to human eyes or very little and yes I tested with infrared tv remote and it is working. I get good pictures but with -ex night option moving objects are blurred...It should be other solutions – user3315730 Mar 9 '15 at 21:24
  • Powerfull illuminator...I mean an infra red illuminator. It's not supposed to be visible to human eyes or very little – user3315730 Mar 9 '15 at 21:24
  • Specifically, what IR light source are you using? Here's a link to one on Amazon that has 96 LEDs amazon.com/CISNO-Infrared-Illuminator-Standard-range-White/dp/… They even have one with 196 LEDs. Also, the -ss option sets the shutter speed in microseconds (millionths of a second). Try -ss 1000000 which should be one second exposure (it will probably also be blurry). – HeatfanJohn Mar 9 '15 at 21:56
1

If you're getting blur on moving objects that means the shutter speed is too long.

The "night" exposure mode allows the shutter speed to ramp up more freely than the default "auto" mode but it should still be limited by framerate (in other words shutter speed can never be longer than 1/framerate, so if framerate is 30fps then shutter speed shouldn't be able to exceed 33.333ms).

You can certainly fix the shutter speed with the -ss option which will eliminate the blurring (assuming you set it fast enough), but don't be surprised if the scene comes back too dark. If the camera is ramping up the shutter speed, I'd assume it's already maxed out the sensor gain, has "decided" the scene is still too dark, and is attempting to compensate with longer exposures.

For that matter, it may be worth checking the camera gains with the raspivid -set option (this dumps shutter speed, analog gain, digital gain, and AWB red/blue gains to the console repeatedly while recording). The maximum gains are 8.0 for both analog and digital. If the analog gain has maxed out, and the shutter speed is still ramping up then you simply need more illumination.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.