1

I am trying to get my SONY CRS60A IR remote to work with LIRC and raspberry pi 2. Here is the setup : enter image description here That is what my setup looks like.

When I run mode2 -d /dev/lirc0 , I am able to read the pulses. But after running IRRECORD(and copying the generated file to /etc/lirc/lirc.d) , when I try to run IRW , and press any buttons on my remote, I get no output.

I had just randomly done this 1 day back, and it had worked then.

What is the problem ? IRSEND is able to send light (i can see from a digital camera) , but the device fails to react to it(I have pointed it directly at it, from a distance of 2 inches)

I am willing to 'reinstall' lirc , deleting all the files generated by it(if its possible, tell me how to )

  • The image isn't very helpful without proper description. – user236012 Mar 11 '15 at 16:28
  • The image is really needed. They are just 2 transistors to amplify the current from the photodiode. I just included to give people an idea of what my setup is – harveyslash Mar 11 '15 at 16:30
  • Take a look at this tutorial. mvartan.com/2014/11/25/… You'll need to verify that you have the models running, and that the lirc service is running. – spuder May 17 '15 at 17:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.