2

I have installed OpenElec 5.0.5 on a Pi (2), fresh install.

I enabled ssh, no problem logging-in, but I want to login without a password. So I copied my ssh key:

ssh-copy-id "root@192.168.0.10x"

It created a .ssh directory on the Pi with a authorized_keys file.

Still when I try to login afterwards, it requests a password. What´s wrong?

  • Did you tried with an other user than root ? root access is often disabled check PermitRootLogin property in /etc/ssh/sshd_config – mpromonet Mar 14 '15 at 14:02
  • It sounds more like it is configured to demand a password regardless, but it is still that sshd_config file you need to change. Post the entire thing and I might be able to point the things out. – goldilocks Mar 14 '15 at 14:09
2

I fixed it by setting ownership of the /storage folder to root:

chown root: /storage

It was owned by 1000, dunno why.

Now it works. Found the ownership hint here

Updated: Also check: permissions on /storage should be 755

chmod 755 /storage

  • In my case changing the ownership of /storage to root:root was not enough. I also had to remove write permissions for the group to /storage (755) – Michael Thessel Sep 17 '15 at 19:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.