0

I am trying to connect to my works hidden network, I know the name of the network and the password but it doesn't want to connect to the network. I can see it when I can and still it will not connect. My phone connects to the network with the same credentials. I am at a loss. I also tried this one with no connection. I can not amend the work's network. Please advise.

The settings are WPA2-Personal. I even hardcoded the details into the wpa-supplicant.conf file and still the same result.

1
  • Anyways, it's solved. For further visitors please add some detail like your wpa-supplicant.conf (of course remove all passwords, hashes, essids and secure data!) Mar 14, 2015 at 19:04

1 Answer 1

2

I reinstalled Respian and then used that link from above and now it works.

my wpa_supplicant.conf file just had these two lines:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

and my config.txt file I did this:

auto lo

iface lo inet loopback
iface eth0 inet dhcp

auto wlan0
allow-hotplug wlan0
iface wlan0 inet dhcp
   wpa-scan-ssid 1
   wpa-ap-scan 1
   wpa-key-mgmt WPA-PSK
   wpa-proto RSN WPA
   wpa-pairwise CCMP TKIP
   wpa-group CCMP TKIP
   wpa-ssid "My Secret SSID"
   wpa-psk "My SSID PSK"

iface default inet dhcp
1
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year.
    – Ingo
    Jan 22, 2020 at 19:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.