I'm using an Edimax EW-7811Un in my Raspberry Pi 2 under Raspbian. Version is Linux stickpi 3.18.7-v7+ #755 SMP PREEMPT Thu Feb 12 17:20:48 GMT 2015 armv7l (or at least that's the closest I can find).

Every time even a single byte tries to go through the adapter, the Pi reboots itself. Including when the Pi is fetching the real-time clock on boot. Using ifdown wlan0 and ifup wlan0 to refresh the DHCP doesn't reboot, however.

The network I'm trying to connect to is configured with a password that I'm certain I've entered correctly, however it requires an additional log-on via a web browser for reasons that are most likely out of the scope of this question - the mere act of connecting to which also causes the reboot to occur.

An Ethernet connection is a no-go until ~4:30 PM Eastern, but I can ferry files via thumb drive if needed.

I wouldn't know if it's any value to diagnosis, but the adapter and the USB port both have gotten warm during my attempts to fix this myself. Switching to other ports don't help.

  • 1
    This sounds like a power issue. Is your power supply strong enough to supply both the Pi and the WiFi-adapter? Mar 17, 2015 at 13:11
  • 1
    I am a special kind of dummy. I didn't even bother looking at my power - 5 V, 500 mA. Guess I need to scrounge for a better PSU.
    – sctjkc01
    Mar 17, 2015 at 13:13

3 Answers 3


This sounds like a power issue. Is your power supply strong enough to supply both the Pi and the WiFi-adapter?

  • That indeed seems to be the issue. However, I'm waiting until I've got a better PSU to check that that's indeed the issue before I consider this the solution.
    – sctjkc01
    Mar 17, 2015 at 13:16
  • 2
    The issue was indeed because of a weak PSU. One jerryrigged PSU later, and I've got stuff downloading and installing.
    – sctjkc01
    Mar 17, 2015 at 19:06

I've had this issue myself with my Raspberry PI A+ and your same adapter.

The system would boot until it got to the point where it inits the WiFi, then shut down and reboot again. Here's things that worked for me:

  • Get a better adapter. This is the "official/right" way to do it. The FAQs recommend at least 1200mA and I was using 1000mA. Upgrading adapters fixed the problem

  • Try plugging into something else. My USB 3.0 port was able to supply enough power for the WiFi adapter.

  • Try a different USB cable. The quality and lenth of your cord matters a lot. My 5'-long cable failed with the 1000mA adapter, while a shorter 3'-long cable worked.

All of this was with an A+, so your mileage may vary.

Again, see the Raspberry PI FAQ topic--it's quite informative.


when looking at wifi adapters, note that any with external antennas will have higher power requirements, in other words, draw more current.

  • While this sounds intuitively right - do you have any references to back up this claim?
    – Ghanima
    Mar 18, 2015 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.