0

I am trying to install Upstart, this is what I do

sudo apt-get install upstart Reading package lists... Done Building dependency tree
Reading state information... Done The following extra packages will be installed: init libjson-c2 libudev1 sysvinit Suggested packages: graphviz upstart-monitor The following NEW packages will be installed: init libjson-c2 libudev1 upstart The following packages will be upgraded: sysvinit 1 upgraded, 4 newly installed, 0 to remove and 295 not upgraded. Need to get 0 B/689 kB of archives. After this operation, 1898 kB of additional disk space will be used. Do you want to continue [Y/n]?

but then I got this error

upstart:armhf conflicts with sysvinit:armhf

How to solve this?

Edit: more complete output

1

Debian have decided to use systemd rather than Upstart.

Raspbian is mainly a recompilation of Debian to work on the Pi and uses systemd with jessie.

I suppose you could try removing systemd.

Why do you want to use Upstart? Which feature do you need?


I get a different message if I want to install Upstart.

sudo apt-get install upstart
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Suggested packages:
  graphviz
The following packages will be REMOVED:
  sysvinit
The following NEW packages will be installed:
  upstart
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  sysvinit
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
Need to get 502 kB of archives.
After this operation, 940 kB of additional disk space will be used.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?] 
  • Well, I planned to use upstart because of my familiarity with it. So is sysvinit, systemd? – user3102569 Mar 18 '15 at 11:31
  • I don't know, I thought sysvinit was an earlier pre systemd initialisation system. I have edited my post with new information. – joan Mar 18 '15 at 11:44
  • Nope, sysvinit is not systemd. Jessie uses systemd by default, or at least it did when I upgraded from wheezy. It may include some sysvinit stuff for backward compatibility. – goldilocks Mar 18 '15 at 12:27
  • I have edited the question – user3102569 Mar 19 '15 at 4:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.