2

I am trying to login from Kubuntu 14.10 PC via Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC adapter with device id 0403:6001. Now, I connect this adapter to rPi B+ GPIO port (RXD, TXT, GND) and connection is ok - triplechecked. Then I turn on minicom via sudo minicom -b 115200 -o -D /dev/ttyUSB0 and instead of nice login screen I get garbage in minicom, which is demonstraed in screenshot. I've triplechecked port parameters in minicom, turned of software and hardware flow control, I did NOT modify /boot/cmdline.txt to disable console mode and it still does not work. What am I missing??Serial Port Garbage. And the second screenshot shows serial port config, which should be ok since rPi boots with /dev/ttyAMA0 115200 8N1 port configurationSerial Port ConfigWell, I do not why, but after checking port parameters with setserial command:

[root@guidetest ~]# setserial -av /dev/ttyAMA0
/dev/ttyAMA0, Line 0, UART: undefined, Port: 0x0000, IRQ: 83
        Baud_base: 187500, close_delay: 50, divisor: 0
        closing_wait: 3000
        Flags: spd_normal

[root@guidetest ~]#

the default baudrate is wrong. Is this maybe kernel/driver bug? I am using kernel Linux guidetest 3.18.9-2-ARCH #1 PREEMPT Wed Mar 11 19:55:21 MDT 2015 armv6l GNU/Linux. I've checked the serial port parameters with stty -F /dev/ttyAMA0 -a and here is output: speed 115200 baud; rows 24; columns 80; line = 0; intr = ^C; quit = ^\; erase = ^?; kill = ^U; eof = ^D; eol = <undef>; eol2 = <undef>; swtch = <undef>; start = ^Q; stop = ^S; susp = ^Z; rprnt = ^R; werase = ^W; lnext = ^V; flush = ^O; min = 1; time = 0; -parenb -parodd -cmspar cs8 hupcl -cstopb cread clocal -crtscts -ignbrk -brkint -ignpar -parmrk -inpck -istrip -inlcr -igncr -icrnl -ixon -ixoff -iuclc -ixany -imaxbel iutf8 opost -olcuc -ocrnl onlcr -onocr -onlret -ofill -ofdel nl0 cr0 tab0 bs0 vt0 ff0 -isig -icanon -iexten -echo -echoe -echok -echonl -noflsh -xcase -tostop -echoprt -echoctl -echoke Is here maybe something wrong?

  • 1
    Sorry, that looks like the wrong baud rate. The Pi boots with 115200 8N1. Another check? – joan Mar 18 '15 at 16:17
  • @joan I've upgraded question with screenshot of port settings. – KernelPanic Mar 18 '15 at 16:42
  • 1
    Get a 'scope on the line. There is so little to go wrong. Check the ground is secure. – joan Mar 18 '15 at 17:08
  • 1
    screen can apparently be used here too, e.g., screen /dev/ttyUSB0 115200. – goldilocks Mar 18 '15 at 17:31
  • 1
    I get the same output as you; I don't make any use of the serial line. I think looking around that Baud_base indicates a maximum speed, which may be arbitrary since you can change it: setserial /dev/ttyAMA0 baud_base 115200 works. This doesn't affect the output from stty even if you make it less. – goldilocks Mar 19 '15 at 19:26
0

I have solved the problem: The cable is faulty and I did not use Serial Pi adapter. I've purchased them both, connected them and now the communication works without any problems!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.