1

I'm trying to start openvpn and transmission-daemon on startup. But using:

sudo update-rc.d transmission-daemon defaults

does not work. They're in the start up services list. But they don't start on reboot. How do I get them to start on reboot?

 [ + ]  avahi-daemon
 [ - ]  bootlogs
 [ ? ]  bootmisc.sh
 [ ? ]  checkfs.sh
 [ ? ]  checkroot-bootclean.sh
 [ - ]  checkroot.sh
 [ - ]  console-setup
 [ - ]  cron
 [ + ]  dbus
 [ ? ]  dropbear
 [ ? ]  hdparm
 [ - ]  hostname.sh
 [ ? ]  hwclock.sh
 [ - ]  kbd
 [ - ]  keyboard-setup
 [ ? ]  killprocs
 [ ? ]  kmod
 [ ? ]  lirc
 [ - ]  minissdpd
 [ - ]  motd
 [ ? ]  mountall-bootclean.sh
 [ ? ]  mountall.sh
 [ ? ]  mountdevsubfs.sh
 [ ? ]  mountkernfs.sh
 [ ? ]  mountnfs-bootclean.sh
 [ ? ]  mountnfs.sh
 [ ? ]  mtab.sh
 [ + ]  network-manager
 [ ? ]  networking
 [ + ]  nfs-common
 [ + ]  ntp
 [ - ]  openvpn
 [ ? ]  plymouth
 [ ? ]  plymouth-log
 [ - ]  procps
 [ ? ]  rc.local
 [ - ]  rmnologin
 [ + ]  rpcbind
 [ - ]  rsync
 [ - ]  rsyslog
 [ - ]  samba
 [ ? ]  screen-cleanup
 [ ? ]  sendsigs
 [ - ]  sudo
 [ - ]  transmission-daemon
 [ + ]  udev
 [ ? ]  udev-mtab
 [ ? ]  umountfs
 [ ? ]  umountnfs.sh
 [ ? ]  umountroot
 [ - ]  urandom
 [ - ]  vsftpd
 [ + ]  winbind
 [ - ]  x11-common
 [ ? ]  xinetd
  • You might want to check what the Default-Start: is in /etc/init.d/transmission-daemon. If it's nothing, try update-rc.d transmission-daemon 2 3 4 5. – goldilocks Mar 20 '15 at 16:05
  • Here's what I'm seeing in that file as-is. Should I add "6" for reboot to Default-Start? # Default-Start: 2 3 4 5 # Default-Stop: 0 1 6 – john Mar 20 '15 at 16:35
  • No, init doesn't differentiate between boot and reboot. 6 is just shutdown. Have you looked in the runlevel directories? E.g. ls /etc/rc2.d | grep transmission? If there is a link there, it has been added as a service, but it is failing. Various people seem to have had problem getting transmission to run at boot. It must log somewhere, so if that link exists in rc2.d, try grep transmission /var/log/syslog to see if there's any info there. – goldilocks Mar 20 '15 at 17:08
1

try rcconf. Make sure to run as root.

$ sudo apt-get install rcconf
$ sudo rcconf

It enables/disables start-up programs. Using it should be pretty straightforward. Up/Down arrow keys for navigation, space bar for enable/disable. Enabled ones have an asterisk inside the checkbox. Press tab, then enter to confirm selections.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.