I have a rasPi-2B, and when I successfully set up the wpa_supplicant.conf file when I was at my house at my college. But, now that I am home for for spring break, I can't get the wifi to work in the same way.

The router here does not have a password set up, so I tried editing the wpa file to have the ssid= the ssid and I had the psk="". That did not work, so I tried psk=, which did not work either. I am unsure what to try.

I also was unsure if the space in the ssid is the issue, if I am supposed to place underscores in the spaces.

EDIT: the content of my interfaces file->

auto wlan
iface wlan inet dhcp
    wireless-essid My SS ID

auto lo

iface lo inet loopback
iface eth0 inet dhcp

allow-hotplug wlan0
iface wlan0 inet manual
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf
iface default inet dhcp
  • If the network is unencrypted don't use wpa_supplicant at all.
    – goldilocks
    Mar 22, 2015 at 12:01
  • @goldilocks how do I set it up to auto connect to my router without wpa-supplicant
    – gangwerz
    Mar 22, 2015 at 16:18
  • I've added an answer, but if you want to manual configure it for both networks (home and school) you should ask how to do that on Unix & Linux.
    – goldilocks
    Mar 22, 2015 at 17:00

2 Answers 2


I don't use the normal configuration methods, but based on this it looks like you want an entry like this in /etc/network/interfaces:

auto wlan0
iface wlan0 inet dhcp
        wireless-essid YOUR_SSID_GOES_HERE

Of course, you probably want to keep the existing listing you have for school -- have a look at this Q&A, which is slightly different but similar circumstances. One of the answers also suggests the use of wicd-curses, which might make all this easier.

If you just want to try to connect temporarily, you could use my method here but use iwconfig instread of wpa_supplicant:

service NetworkManager stop
ip link set wlan0 up
iwconfig wlan0 essid YOUR_ESSID
dhclient -v wlan0 

All that has to be done sudo.

  • I tried this, but I still cannot connect
    – gangwerz
    Mar 22, 2015 at 21:38
  • My SSID is three words, with spaces. I don't know if this would effect how I enter it.
    – gangwerz
    Mar 22, 2015 at 21:39
  • 1
    try surrounding ESSID with single quotation marks or double quotation marks. 'name of AP' or "name of AP" If that doesn't work, there are some other possible ways to encode a space but I'm not sure what iwconfig will accept. Mar 24, 2015 at 14:20
  • Sorry, I missed that yesterday. You can also pass spaces this way: one\ two\ three but "one two three" should be fine.
    – goldilocks
    Mar 24, 2015 at 14:25

I always start x and just use wpa_gui.

  • 1
    Unlikely to work if the network does not use WPA encryption, which requires a password. Hence, if this is a network with no password -- as described in the question -- it is not WPA encrypted.
    – goldilocks
    May 2, 2015 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.