Hoping someone could help verify something for me.

Up until a few days ago, my Edimax EW-7811UN was happily buzzing along. I was playing around with the GPIO pins when suddenly I noticed the blue light inside the dongle stop flashing.

Thinking that I had possibly shorted out the Pi and it had reset, I waited for boot and for the light to begin flashing again, but it didn't.

I then tried the device using another SD card, different OS, in the same Pi. Running lsusb, I could not see the device listed. I then tried 2 other Pi's, each with different OS's to no avail. Nothing listed under lsusb.

The strange thing is that if I plug the dongle into my laptop, Windows 8 detects and installs it, I can connect to my wireless network and browse the internet.

Is it possible it may be fried somehow, and the Pi can't supply enough volts to it, where the laptop can?

Any help appreciated.

  • 2
    Do you have a powered usb hub yuo could try the dongle on? Mar 22, 2015 at 18:55
  • do other USB devices work in the same port on the Pi?
    – rob
    Mar 23, 2015 at 10:04
  • Sorry for late reply. Yeah, have tried numerous devices, keyboards, mice, gamepads. All fine. Interestingly, I loaded an SD card with Arch tonight, plugged in the dongle, and powered up. Running lsusb showed the Edimax listed in the devices. So I ran ip link set wlan0 up, and then received a few lines detailing errors. The obvious line said the usb was disconnected. The only way to make it show up again was by rebooting the Pi. Was late when a tried this, will post error messages tomorrow.
    – thekman31
    Apr 6, 2015 at 15:01
  • ok, so running lsusb shows this output amongst the other USB devices: Bus 001 Device 004: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un then running ip link set wlan0 up then disconnects the device. The following messages show up in dmesg [ 69.643226] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready [ 69.751025] usb 1-1.2: USB disconnect, device number 4 [ 69.758622] rtw_cmd_thread: DriverStopped(0) SurpriseRemoved(1) break at line 482. Any clues anybody?
    – thekman31
    Apr 7, 2015 at 14:30
  • I am having the same problem on a raspberry pi A+. The dongle has suddenly stopped working in full use and since, impossible to make it work. When I run the command lsusb the rapsberry pi does not detect the wifi dongle (same model). Then, when I plug the dongle on my other PC, Fedora, lsusb is detecting the dongle (Bus 002 Device 005: ID 7392:7811 Edimax Technology Co., Ltd EW-7811Un 802.11n Wireless Adapter [Realtek RTL8188CUS]).
    – user29262
    Apr 24, 2015 at 6:53

2 Answers 2


I had this problem and putting "dwc_otg.speed=1" in my /boot/cmdline.txt fixed it. What that does is make the Pi treat the Edimax as a USB 1.1 device (rather than the 2.0 device it is). That cuts your theoretical throughput from 480 Mbps to 12, but even 12 is likely more than your Wifi access point will supply anyway.

Unfortunately, sometimes even this doesn't do it. In that case, I boot up the Pi without the Edimax, and then I insert the Edimax after the Pi is up. I have no idea why hotplug would be more reliable than coldplug. But in any event, before the dwc_otg.speed=1 thing, the success rate was zero percent.

  • 2
    Hello and welcome! Would putting the USB OTG controller into USB 1.1 mode not also affect all other devices attached? Such as USB flash drives and so on - could be a major PITA.
    – Ghanima
    Jun 2, 2015 at 8:40
  • I'm finding 12 Mbps far better than the previous 0 bps. How much of a PITA this is for you depends on how fast you need to blow bits out YA. Jun 2, 2015 at 19:20
  • 12 is definitely better than 0, but it would be helpful for anyone tempted to give this a whirl if you could include a very brief 'this change will affect all USB sockets' in the answer somewhere. I know what's going to happen, you know what's going to happen - someone out there who doesn't know is going to change the setting and be bewildered as to why their USB doodads have reverted to 1998.
    – goobering
    Feb 2, 2017 at 18:07

I've come to believe the Edimax 7811un really does have some problems. I deployed dozens of Pi systems as door access controllers and most of them use the Edimax dongle for WiFi. In my application they only connect to the network for a few moments once a day to exchange information with a host. In the last few months, the automated scripts that use "iwconfig" and "dhclient" commands to grab (and then drop) a lease will sometimes fail, saying that wlan0 does not exist. Soft rebooting (from the console) does not bring them back. Power cycling does, but anymore, I've found I can just unplug them from the Pi and plug them back in: the blue light flashes, and everything is happy. It is not at all predictable, and on the older Pi systems I used in most of the installations, there's no way in software to power cycle the USB ports. Newer installations use Pis with built-in networking. Since a lot of the systems started having this happen at the same time, I am thinking there may be a heat-related degradation of reliability over time due to under-design.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.