1

My Raspberry Pi boots into Emulation Station.

Whenever I turn on my television it starts with input set to HDMI 2 (the HDMI port that the Raspberry Pi is attached to) regardless of what it was set to when i turned it off. It never did this before I had a Raspberry Pi plugged into it. Also, a message appears on the screen which says "Device Control Active". Is there a way to disable this behavior (short of turning off or unplugging the Raspberry Pi)?

  • Does it do this only when the pi is actually running, or when it's been shutdown but the power is still on? I'm guessing the former, otherwise you might as well leave it unplugged. If so, and emulation station's display never goes to sleep, and your TV does not allow you force which input to use, I think you are out of luck. HDMI devices like TV's and monitors have gotten annoying this way -- rather than allowing you to decide what the input should be, they will go to which ever one is active. Supposedly that is a feature. :/ – goldilocks Mar 24 '15 at 13:06
  • Your TV may have an option to disable this. Look for "Device Control", "CEC", or "auto input selection" in your setup menus. – TomG Mar 25 '15 at 1:38
  • Try moving the Pi to the last / highest HDMI input. Some TVs prioritise which input to use based on what signals they can detect, going from lowest input onwards, so if you put the Pi at the end, your other devices may get priority. – Surfbutler Jun 23 '15 at 20:54
  • 3
    Possible duplicate of stopping RaspPi / raspbmc from auto changing source on tv – Erik Jul 21 '16 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.