3

If I start up emacs without the GUI (without startx), using the emacs command, a buffer labeled *GNU Emacs* is displayed. On top it says "Welcome to GNU Emacs".

In this screen, there is a menu item labeled "Read the Emacs Manual". If I follow this link (or type the shortcut C-h r), it tells me "Info file emacs does not exist". On my mac, I can view this page.

I have tried sudo apt-get install emacs, but that just tells me I already have the latest version. I have also tried to guess other package names like emacs-doc, but to no avail.

Question: How to install the emacs documentation (using apt-get)?

3

My question was answered here: https://askubuntu.com/q/572026

The solution for me was

sudo apt-get install emacs23-common-non-dfsg

Note that maybe you should probably replace the 23 by the version you are running, though version 23 is probably the "default" version right now. To find your version of emacs simple do emacs --version. After installing this package, the shortcut C-h r worked fine in emacs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.