16

I installed my Raspberry Pi out of the box. Unfortunately, I can't seem to find neither nslookup nor dig.

Where can I find them? Which package do I need to add?

  • uname -a is:

    Linux brambleberry 3.12.28+ #709 PREEMPT Mon Sep 8 15:28:00 BST 2014 armv6l GNU/Linux
    
  • From file /etc/os-release:

    PRETTY_NAME="Raspbian GNU/Linux 7 (wheezy)"
    
  • 2
    try sudo apt-get install dnsutils – rob Mar 25 '15 at 9:12
20

Use

 sudo apt-get install dnsutils

After installation, nslookup now works:

me > nslookup 8.8.8.8
Server:         192.168.1.1
Address:        192.168.1.1#53

Non-authoritative answer:
8.8.8.8.in-addr.arpa    name = google-public-dns-a.google.com.

Authoritative answers can be found from:
  • 1
    Have a look here if you want to know how to figure this out. That question is closed, but rob's answer on it is worth reading because it uses the --regex option to apt-file (which is explained in my answer). You can always click through to the duplicate as well. – goldilocks Mar 25 '15 at 13:54
  • When I tried it, I got "Err http://mirrordirector.raspbian.org/raspbian/ wheezy/main libisc84 armhf 1:9.8.4.dfsg.P1-6+nmu2+deb7u3 404 Not Found" (and seven other 404's). (I have Debian 7.8/ kernel 3.18.7 - and the same content in /etc/os-release as in the question.) – Peter Mortensen Oct 27 '15 at 13:19
  • Doing sudo apt-get update and sudo apt-get fixed the problem, as in an answer to "apt-get installation doesn't work on Raspberry Pi". – Peter Mortensen Oct 27 '15 at 14:35
  • I tried it on a second Raspberry Pi. Only the first, sudo apt-get update, is necessary (potentially saving hundreds of megabytes download (and a lot of time)). – Peter Mortensen Oct 27 '15 at 20:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.