0

I currently have a Raspberry Pi Model B+ with Raspbian OS installed. Recently, I have tried to install BitTorrent Sync on my raspberry pi and after following this tutorial, I managed to get

BitTorrent Sync forked to background. pid = 2254. default port = 8888

after executing

./btsync

This shows that BtSync is successfully running. But the problem is, after going on my computer and navigating to [MyRpiIP]:8888/gui, I get the "This webpage is not available" error by Chrome.

Is there any way I can fix this? The Raspberry pi is on the same network as me.

  • Can you ping or SSH into the Pi? If not, then my guess would be that the Pi is having issues with the 8888 port and your router. Do you have anything else running on the Pi that is serving web content? Also, try just going to [raspberrypiIP]:8888 and see if that does anything. – RPiAwesomeness Mar 26 '15 at 19:11
  • I can successfully ping and SSH to the pi. There are no other web services running. I tried accessing [raspberrypiIP]:8888 but that doesn't work. It's strange, I have had other services work 100%. Is there a way to change the port of the BTSync Service? – Shayan Doust Mar 26 '15 at 20:10
  • Just a quick update. Chrome error code is ERR_CONNECTION_REFUSED – Shayan Doust Mar 26 '15 at 21:41
  • Sounds like you don't actually have that port open. Can you run ` netstat -pln` and give me the output? Also, after doing that, try running sudo iptables -A INPUT -p tcp --dport 8888 0 -j ACCEPT then sudo iptable-save and seeing if it works. – RPiAwesomeness Mar 27 '15 at 1:30
  • Can you try to "wget 127.0.0.1:8888/gui" and see if an html file appears in the current directory? – portforwardpodcast Mar 27 '15 at 2:42
1

You have to use:

./btsync --webui.listen 0.0.0.0:8888

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.