1

I have a external drive that is formatted in HFSX. And I have installed the hfsplus etc using

sudo apt-get install hfsplus hfsutils hfsprogs

After this I have retrieved the UUID for the disk using ls -l /dev/disk/by-uuid/ (lets say it was 12345)

And then created a folder /mount/USBDrive/ and tried to mount the device into this folder using

sudo mount -t hfsplus -o force,rw UUID=12345 /media/UDBDrive/ 

This seem to work super and I see all my files etc. Now I would like to add this into my fstab and this is when the problem starts...

So in my /etc/fstab file I add the row

UUID=12345 /media/USBDrive/ hfsplus force,rw,default 0 0

(I'm not sure about the force,rw but I have tried without it and it makes no differens)

Anyway, after adding this to my fstab I run sudo mount /media/USBDrive/ and I get the following error message:

mount: wrong fs type, bad option, bad superblock on /dev/sda2,
       missing codepage or helper program, or other error
       In some cases useful info is found in syslog - try
       dmesg | tail  or so

and the dmesg reports:

hfsplus: unable to parse mount options

Soo... Why can I mount it using the "manual" mount command, but not using the fstab?

2

Just copy the options that you used on the command line:

UUID=12345 /media/USBDrive/ hfsplus force,rw

The 0 0 part at the end is optional. You tried with the extra option default which is not a valid option name (there's a defaults, but it isn't useful here).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.