I am trying to get my eth0 interface working on the Pi. It is not getting a DHCP lease - DHCP works perfectly fine over wlan0 though. sudo ifup eth0 is returning:

Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Listening on LPF/eth0/xx:xx:xx:xx:xx:xx
Sending on   LPF/eth0/xx:xx:xx:xx:xx:xx
Sending on   Socket/fallback
DHCPDISCOVER on eth0 to port 67 interval 5
DHCPDISCOVER on eth0 to port 67 interval 14
DHCPDISCOVER on eth0 to port 67 interval 10
DHCPDISCOVER on eth0 to port 67 interval 12
DHCPDISCOVER on eth0 to port 67 interval 19
DHCPDISCOVER on eth0 to port 67 interval 1
No DHCPOFFERS received.
No working leases in persistent database - sleeping.

I am running Raspbian 20150216.

3 Answers 3


With a raspberry pi there can often be power problems. If your ethernet does not work, for debugging, also try

If it works without usb or other devices attached, you may want to

  • use a powered usb hub, connect the devices to that and the hub to the pi
  • use a different power adapter.

You can also check for issues or post new ones in the official issue tracker.

  • 1
    The first thing you mention was the issue for me! I switched from a wireless keyboard to a simpler wired keyboard, and it looks like that freed up enough resources for eth0 to work properly.
    – JHS
    Commented May 22, 2017 at 0:27

No DHCPOFFERS received is quite self-explanatory. The device your pi is connected to (maybe a router?) is not giving or assigning DHCP offers/addresses. Check your router of it is configured to give out IP addresses (i.e. configure it as a DHCP server, not a relay/client).

Another alternative would be to configure your pi to use a static IP address. This setup would not need any DHCP magic whatsoever. Look here if you would like that.


I had exactly the same issue and solved that as explained here with adding a lower priority metric (e.g. metric 100) to the 2nd interface. So based on that finding the following configurations is working for me. If that isn´t done it looks like the routing is confused and is trying to do the DHCP via the LAN connection. In my case I ALWAYS got a IP via wlan on both devices when I have a LAN wire. Did I removed the LAN wire DHCP was also not working via WLAN, the metric part solved my issue.


auto lo
iface lo inet loopback

auto wlan0
allow-hotplug wlan0
iface wlan inet dhcp
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf 

auto eth0
iface eth0 inet dhcp
metric 100
  • This seems to solve my problem, which is the opposite: eth0 declared before wlan0, with dhcp not working on wlan0 (not getting any lease with ifup/ifdown, while dhcpcd would work). Adding metric 100 to the wlan0 section did the trick.
    – MayeulC
    Commented Sep 20, 2018 at 15:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.