I'm currently using Raspbian as my raspberry OS, but the rsync package that comes with it is at version 3.0.9, and I need version 3.1.0 or above. I've tried to upgrade but there's no new package available.

Do I need to add a new repository to apt-get? And how can I do it?

I've also tried to download from http://rsync.samba.org/ftp/rsync/src/rsync-3.1.1.tar.gz and compile, but when I run 'make install' it shows:

/bin/mkdir -p /usr/local/bin
/usr/bin/install -c  -m 755 rsync /usr/local/bin
/bin/mkdir -p /usr/local/share/man/man1
/bin/mkdir -p /usr/local/share/man/man5
if test -f rsync.1; then /usr/bin/install -c -m 644 rsync.1 /usr/local/share/man/man1; fi
if test -f rsyncd.conf.5; then /usr/bin/install -c -m 644 rsyncd.conf.5 /usr/local/share/man/man5; fi

I believe that it's not fully 'installing'. If there's some more info you guys need, please tell me.

  • can you run the rsync binary that you built directly from the folder you unzip everything? It looks like it is just not moving the binary. Try running the install step with sudo
    – rob
    Apr 1 '15 at 8:27
  • I'm downloading the tar to ~/Downloads, running 'sudo ./configure', then 'sudo make' and finally 'sudo make install'. What do you mean by 'rsync binary'? Apr 1 '15 at 19:18
  • Ok, I got how to run the rsync binary by running './rsync', how can I replace the default one? Apr 1 '15 at 19:24
  • outside the folder you built the binary run which rsync that will tell you where the system binary is you can rename it and then copy your new one over it. Beware that updating raspbian may automatically replace it when you update. Might be best to uninstall it first then copy your binary.
    – rob
    Apr 2 '15 at 7:12
  • rob, you're correct, can you answer the question so I can accept and "close" it? Apr 2 '15 at 13:39

It looks like the binary is being built successfully but not getting installed. The installation step should just be replacing the system Rsync binary.

Although you could find where the file is by running where rsync and copying your custom built binary over it. I would suggest you instead uninstall rsync first to avoid any future system updates overwriting the replacement.


Based on the log excerpt, the install was successful. If you chose all the defaults when compiling the source, it installed into /usr/local/bin. You should see it in there if you do an ls.

The default installed by apt-get installs into /usr/bin.

Assuming that /usr/local/bin precedes /usr/bin in your PATH, then just running rsync should find the correct version.

pi@kd-pi ~ $ echo $PATH

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.