I tried almost all the options, but unfortunately I fail to get my Raspberry Pi 2 to boot up. At power, light is still two LEDs (red + green) but nothing further happens.

  1. Power supply - tested 2 x AC / USB + external power USB HUB
  2. microSD - 8GB A-DATA according Compatibility List OK

Thank you for your help.

  • When you power up the Pi with a SD card inserted what do the LEDs do? What flashes if any? Have you measured the voltage on the board?
    – joan
    Commented Apr 3, 2015 at 10:35
  • 1
    Situation is the same....with microSD or without. When I plug in power usb cable both of leds begin to shine.
    – Tom
    Commented Apr 3, 2015 at 11:47
  • Situation is the same....with microSD or without. When I plug in power usb cable both of leds begin to shine. And nothing happens...
    – Tom
    Commented Apr 3, 2015 at 11:54
  • That suggests the SD card has not been written properly. How and what have you written to the SD card?
    – joan
    Commented Apr 3, 2015 at 12:14
  • 1
    What you describe should have worked. I suggest you ignore NOOBS and download the Raspbian image instead. If Raspbian works you can always try NOOBS again later.
    – joan
    Commented Apr 3, 2015 at 13:15

8 Answers 8


Last time I had this problem the sd card was broken. I had to insert another card in the pi. Insert the card in another pc and see if it's accessible. If is then reformat the sd card with an fresh pi installation. That solved my problems.

  • Just ran into same issue on Raspberry Pi 2B - constant red and green lights. Issue was an aborted update had messed up my Raspbian image somehow. Reformatted and flashed the card with a new Raspbian image and all was good
    – Frank
    Commented Dec 29, 2022 at 23:39

I got solid red and green lights on my little Pi 2B due to simply copying the file contents over rather than following the instructions here. Fixing my SD card fixed the problem.

For me simply doing a cp didn't work but using dd did.


My Raspberry was working for months. It stopped working. Starting up didn't work. Solid green and red light.

The fix:

  • put SD card in laptop/PC
  • on SD card, use default Windows 'scan for problems'
  • In my case Windows found some issues. I chose to fix the problems
  • place SD in Raspberry
  • Raspberry booted successfully

OK, I spent two days troubleshooting my RPi 2 B+. It always worked great from the time I purchased it. Although, a couple of times I had to re-image the SD card. Easily done. This time when my pi went down I got red and green constant lights (no green flashing). I went thru every post I could find from adapter to test points to cleaning the sd card slot and tried 3 different sd cards from different manufacturers(one being the card it had used since I bought the pi).

Final fix:

Instead of using SD formatter to format the card, I used the Toshiba SD card formatter on my laptop.


I had this problem and checked the answers here, then noticed that my problem was a bad partition structure. I have mistakenly formatted partition as logical, problem solved after converting it to primary partition.


I had a similar issue with the newest versions of Raspbian but also with Ubuntu.

  1. Insert the SD in a computer and mount /boot partition
  2. Edit the file config.txt
  3. Search for hdmi_force_hotplug and set it to 1. Usually you just need to uncomment the line
  4. If you are working in console mode, you may also want to set framebuffer_height=720 or 1280.
  5. Save, sync few times, then unmount.

Hope it helps.


I'm a little late to the party but have you checked for dust? I have a Pi set up as a 3d Printer server that didn't boot one day. It looked it a little dusty so I used some compressed air on it and now it boots just fine!


Also late to the party, but thought I'd add that this behavior (solid red and green lights/LEDs at boot time) also happens if the SD card is formatted as exFAT.

exFAT is the default on Windows with SD cards over 32 Gb and also seems to be the default format for large SD cards in Tuxera's SD Card Formatter on MacOS (from sdcard.org).

To work around the exFAT issue, reformat the SD card in FAT or FAT32 before copying the NOOBS files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.