0

Following the Readme instructions (as well as other websites), I get some errors when using the make command while building Shairport. I configure it and it all seems okay:

pi@retropie ~/shairport $ sudo ./configure
Configuring Shairport
OpenSSL found
libao found
PulseAudio found
ALSA found
Avahi client found
getopt.h not found
CFLAGS: -D_REENTRANT -I/usr/include/alsa -D_REENTRANT
LDFLAGS: -lm -lpthread -lssl -lcrypto -lao -lpulse-simple -lpulse -lasound -lavahi-common -lavahi-client
Configure successful. You may now build with 'make'

But when I do the make command, I get an error and I cannot figure out the problem:

pi@retropie ~/shairport $ sudo make
cc -c -O2 -Wall -D_REENTRANT   -I/usr/include/alsa   -D_REENTRANT   shairport.c
cc1: error: /usr/local/include/arm-linux-gnueabihf: Not a directory
cc1: warning: /usr/local/include: not a directory [enabled by default]
Makefile:60: recipe for target 'shairport.o' failed
make: *** [shairport.o] Error 1

My best guess is that there is something missing in RetroPie.

https://github.com/abrasive/shairport

  • Also, I just found out that it isn't just shairport, it's any time I try to use the make command. – AaronWilliams Apr 6 '15 at 17:45
1

I figured it out:

In the /usr/local directory were two files, include and lib. I deleted the two files and re-ran the make command and it all worked well. I guess it cannot create directories with the same names as files in a directory.

Found it here.

  • Yeah, /usr/local/include and lib should have been directories from the start (but they would have been empty), owned root-root and set 0755 (you can check this with stat, but if sudo make made them it should be fine). Something weird must have happened at some point... – goldilocks Apr 7 '15 at 19:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.