1

i can't display images from my webcam using mplayer

i followed this article: monitor a webcam

but i got this error:

pi@raspberrypi ~ $ mplayer tv:///dev/video0
MPlayer svn r34540 (Raspbian), built with gcc-4.6 (C) 2000-2012 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing tv:///dev/video0.
The filename option must be an integer: dev/video0
Struct tv, field filename parsing error: dev/video0
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski <olschewski@zpr.uni-koeln.de>
comment: first try, more to come ;-)
v4l2: your device driver does not support VIDIOC_G_STD ioctl, VIDIOC_G_PARM was used instead.
Selected device: USB Camera (05a9:a511)
Capabilities:  video capture  read/write  streaming
supported norms:
inputs: 0 = ov519;
Current input: 0
Current format: unknown (0x3131354f)
tv.c: norm_from_string(pal): Bogus norm parameter, setting default.
v4l2: ioctl enum norm failed: Inappropriate ioctl for device
Error: Cannot set norm!
Selected input hasn't got a tuner!
v4l2: ioctl set mute failed: Invalid argument
v4l2: ioctl query control failed: Invalid argument
Xlib:  extension "XFree86-VidModeExtension" missing on display "localhost:10.0".
Xlib:  extension "XVideo" missing on display "localhost:10.0".
[VO_XV] Sorry, Xv not supported by this X11 version/driver
[VO_XV] ******** Try with  -vo x11  or  -vo sdl  *********
==========================================================================
Cannot find codec matching selected -vo and video format 0x3131354F.
==========================================================================

v4l2: ioctl set mute failed: Invalid argument
v4l2: 3 frames successfully processed, 1 frames dropped.

Exiting... (End of file)

i'm a real beginner with Linux so if someone can give me any suggestions, or a start point to investigate... it would be great!

note aside:

  • the webcam is a creative ct6840

  • the output of the command: ls -ltr /dev/video* is crw-rw—-+ 1 root video 81, 0 Nov 11 09:06 /dev/video0

  • I plugged in a webcam into my system and tried the command. I did not get the same error as you and saw video (my greens were red, my reds were green and my blues were magenta :-) Are you running the command in a X-Windows environment? Did you run "startx"? – Kolban Apr 6 '15 at 22:40
  • i tried from the shell and from a x-Windows session as well, same error! – alex Apr 8 '15 at 8:11
  • [VO_XV] Sorry, Xv not supported by this X11 version/driver [VO_XV] ******** Try with -vo x11 or -vo sdl ********* i tried to pass these options as well but i got the same error – alex Apr 13 '15 at 15:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.