3

I'm getting following message inside of wpa_gui:

Status: Could not get status from wpa_supplicant
Last Message: -signal 15 received

What is signal 15? I tried clicking on Disconnect & Connect, but nothing seems to be working for me other then Menu -> Shutdown -> Reboot.

Is there a service I can restart, so I don't have to rebooting my Raspberry?

  • Signal 15 is SIGTERM, but I guess that doesn't help you much. It's a polite way of asking a process to stop, but it can be ignored. Have you tried restarting wpa_gui? You could also try service NetworkManager restart... – goldilocks Apr 6 '15 at 15:51
  • I tried restarting wpa_gui that did not help, but I got new Status: Could not get status from wpa_supplicant, and service NetworkManager restart returns NetworkManager: unrecognized service – alexus Apr 6 '15 at 16:08
  • Sorry -- Raspbian doesn't use that by default and it is probably for the best. How about service networking restart? I can't promise anything but it is worth a try. – goldilocks Apr 6 '15 at 16:12
  • that i tried, however that did not help me resolve my question( (still same Status: Could not get status from wpa_supplicant) – alexus Apr 6 '15 at 16:15
  • Hmmm. In order sudo service networking stop (ignore it if it won't), sudo killall -9 wpa_supplicant, sudo service networking start. – goldilocks Apr 6 '15 at 16:53
1

I had the same problem. In my case it turned out that the input power to the Raspberry was too low. Source transformer had an output of 700mA (and 5.5v of course, since it is USB). I had connected via usb a TP Link device for the wifi connection and USB mouse and keyboard via a hub on the other USB port. That was (I guess) above the 700mA. I replace the transformer with a different one that have 1A output and I can use at the same time the usb hub and the TP link access point without the annoying signal 15 popping up. I hope it helps

  • I've tried @work w/ 850ma and home w/ 1A and got same thing( – alexus Jun 24 '15 at 20:48
  • I am using the Power Adapter that comes with the Canakit Complete Starter Kit and I'm having the same issue. – Christoph Jun 28 '15 at 22:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.