0

I have a Raspberry Pi 2 running for quite some time now with the default raspbian image from the raspberry homepage. I have tightvncserver set up which was also working like a charm until I mistakenly powered down the raspberry.

After the reboot vnc sessions only show me a black & white "rasterized" screen whilst the X server seems to be running fine since I see the usual desktop when connection over HDMI.

enter image description here

I've already tried to simply uninstall & reinstall tightvncserver which didn't change a thing. Also subsequent reboots didn't work.


Conclusion:

I somehow messed up some permissions in my home folder. Among others, the file /home/user/.vnc/xstartup didn't have the execute permissions anymore set and therefore didn't start correctly...

  • That's an Xorg server running with no DE/WM, as you've realized. – goldilocks Apr 9 '15 at 14:44
  • How did you resolve this issue @suamikim ? I am facing this issue right now and i am not sure how do i get around it. Thanks – Girish Sortur Dec 27 '15 at 14:50
1

This issue is caused when the server application is unable to start your desktop window manager.
This can be caused by wrong permissions on your xstartup file (as you have identified)
It can also happen if the xstartup file does not allow a suitable DWM to start, this can happen if the DWM it attempts to start is no longer installed, or if the DWM it wishes to start requires hardware acceleration.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.