1

(Full disclosure: I've asked a question on the desktop side of this process over on Ask Ubuntu.)

I have my speakers connected to my Pi (running OSMC). However, when I'm using my desktop PC (running Ubuntu 14.04), I want them to output the audio of that. So I figured: I can probably stream the audio from there to the Pi, since they're both on the same home network.

I'm not quire sure how to do that though. Based on what I've read about it until now, it looks like I'd want to use RTP. Thus, I configured my desktop to be a Multicast/RTP sender (screenshot), installed PulseAudio on OSMC, edited /etc/pulse/default.pa to enable pactl load-module module-rtp-recv, and then started PulseAudio.

When I'm playing audio on my desktop, though, the Pi doesn't output it. What should I do to make this work? (Is RTP even the right approach?)

  • Further questions about pulseaudio are better off on Unix & Linux (or AskUbuntu) as there's nothing special about using it on the pi. – goldilocks Apr 11 '15 at 15:21
  • So many exchanges... But thanks! The answer to that duplicate looks promising, and otherwise I'll ask over there. – Vincent Apr 11 '15 at 15:59