1

I need the drivers for my wireless adapter (TP-LINK TL-WN723N v3). I googled a lot, but could not find latest drivers. All I could find were the drivers for TP-LINK TL-WN725N. My raspbian version is 3.18.7-v7+ #755. Will these drivers work for me?

Otherwise, is there any way that I can compile the drivers myself?

  • Have you tried plugging it in? If there's a driver for it you should see wlan0 listed with ip link. If that doesn't work try sudo modprobe 8192cu and ip link again, but I don't think there's a driver for this one. – goldilocks Apr 12 '15 at 11:29
  • I tried both but it lists only lo and eth0. I tried installing the drivers or TL-WN725N, but still the same. – Aakash Jog Apr 12 '15 at 11:36
2

TP-LINK TL-WN723N v3 uses the same chipset as TP-LINK TL-WN723N v2. So, I solved the problem by installing the drivers for the same.

These links were helpful.

https://www.raspberrypi.org/forums/viewtopic.php?p=422209 https://www.raspberrypi.org/forums/viewtopic.php?f=28&t=62371

I also had to reinstall the firmware-realtek package.

0

It has been my experience that you need to by a compatible wifi device as drivers are not always available for the device you have. I use usb wifi adapters that contain Realtek chipsets: rtl8176 and rtl 8188CE. I purchased my wifi adapters from Adafruit, Amazon and Fry's Electronic. Be sure to check the chipset before you buy! Hope this helps.

0

If you want a completely automatic download/install (Raspberry Pi2 only) program check here. This installer is for TL-WN725N, but, mentioned, it should work the same. It makes also simpler to install the driver after updating the operating system, and allows you to install even without requiring a connection different from the one provided by the wifi adapter!

  • Your link goes to an installer for the TL-WN725N, rather than the TL-WN723N. Can you confirm that that driver is compatible? – goobering Mar 18 '16 at 0:38
  • Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Ghanima Mar 18 '16 at 0:40
  • you say as someone mentioned... who mentioned this? Can you cite a source for that confirmation? – Greenonline Mar 18 '16 at 11:53
  • The top comment has mentioned it, and it has been accepted as best answer, so it's assumable that it worked. The second link redirects to the TL-WN725N drivers list – Carlo Mar 18 '16 at 12:50
0

Maybe this answer is a bit late, but for all the others who are still looking:

To have the TP-Link TL-WN725N v2 and v3 working use the following commands in the terminal

First type:

$ sudo su -

Then type

$ wget http://raspishop.pl/downloads/8188eu.ko-raspbian -O /lib/modules/`uname -r`/kernel/drivers/net/wireless/8188eu.ko

And after that

$ depmod -a

Next type the following command

$ sed -i 's/^exit 0/modprobe 8188eu\nexit 0/' /etc/rc.local

Finally, reboot using

$ reboot

This worked perfectly for me. I have a way better wi-fi connection now

  • You should put the module that needs to be loaded at boot time in /etc/modules and the kernel will modprobe it automatically. No need for any changes to /etc/rc.local. – Dougie Aug 2 at 11:42
  • Why would you use sudo su? – RalfFriedl Aug 2 at 12:52
  • @RalfFriedl because it looks cleaner. using <code>sudo su - </code>will automatically put you in as a root user. You don't have to type sudo before every command – Chiel Aug 2 at 13:11
  • I prefer to use sudo -Es instead of sudo su - because then you have a known environment. Please take note that using /etc/rc.local has limitations due to Compatibility with SysV. We have seen many problems here on this site using it. Following the recommendation of the developers from systemd you should avoid using it. – Ingo Aug 2 at 17:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.